Changing data structure forced command termination
Posted in 2006
Topics: General Discussion
We have a problem with an IBM xSeries server running SCO OpenServer Enterpise
5.0.5 and Informix Dynamic Server Version 7.30.UC2. When trying to use any
onstat command we get the error "Changing data structure forced command
termination" and when trying to run onmonitor get the error "shmdt: errno =
22". If we try to select any option in onmonitor we get the error "Unable to
attach to shared memory".
Aside from this, the informix server is actually running perfectly, the only
problems I've seen in the Informix log are where it seems to dynamically
assign more shared memory and then round it:
It should be doing this:-
dynamically allocated new shared memory segment (size 8388608)
But it's now doing this:-
dynamically allocated new shared memory segment (size 8388608)
Requested shared memory segment size rounded from 10576KB to 12288KB
dynamically allocated new shared memory segment (size 10829824)
Any assistance would be greatly appreciated.
Regards,
Paul.
Paul
The first errors would tend to indicate the version of IDS
running is incompatible with the version of onstat/onmonitor
you are trying to use. This may be confirmed by new memory
messages. I have always seen this type of rounding up (in IDS
7.31 and above).
Have you attempted an upgrade on this instance? Have you
installed a later version of IDS and got your $INFORMIXDIR or
$PATH muddled?
Is there anything in the log file around where the memory
message changes?
Keith
-> -----Original Message-----
-> From: PAUL COOPER [mailto:pcooper@wharncliffe.co.uk]
-> Sent: Friday, July 21, 2006 10:04 AM
-> To: ids@iiug.org
-> Subject: Changing data structure forced command termination [7150]
->
->
->
-> We have a problem with an IBM xSeries server running SCO
-> OpenServer Enterpise
-> 5.0.5 and Informix Dynamic Server Version 7.30.UC2. When
-> trying to use any
-> onstat command we get the error "Changing data structure
-> forced command
-> termination" and when trying to run onmonitor get the error
-> "shmdt: errno =
-> 22". If we try to select any option in onmonitor we get the
-> error "Unable to
-> attach to shared memory".
->
-> Aside from this, the informix server is actually running
-> perfectly, the only
-> problems I've seen in the Informix log are where it seems to
-> dynamically
-> assign more shared memory and then round it:
->
-> It should be doing this:-
->
-> dynamically allocated new shared memory segment (size 8388608)
->
-> But it's now doing this:-
->
-> dynamically allocated new shared memory segment (size 8388608)
-> Requested shared memory segment size rounded from 10576KB to 12288KB
-> dynamically allocated new shared memory segment (size 10829824)
->
-> Any assistance would be greatly appreciated.
->
-> Regards,
->
-> Paul.
->
->
-> *************************************************************
-> ******************
-> Forum Note: Use "Reply" to post a response in the
-> discussion forum.
->
********************************************************************************
***************
This message is sent in strict confidence for the addressee only. It may
contain legally privileged information. The contents are not to be disclosed
to anyone other than the addressee. Unauthorised recipients are requested to
preserve this confidentiality and to advise the sender immediately of any
error in transmission.
This footnote also confirms that this email message has been swept for the
presence of computer viruses, however we cannot guarantee that this message is
free from such problems.
********************************************************************************
***************
Hi Paul,
I have seen this before. Does this situation only occur when Informix has
attempted to allocate more memory? Does it work again, after Informix has
been stopped and restarted? (or even a reboot of the server).
Perhaps you have run out of memory, to use the onstat commands? You could
try to set the total memory parameter in the onconfig file lower (or alter
from zero).
Another point to note; there are lots of bugs in this version of Informix,
and it is no longer a supported release. I would upgrade as soon as
possible.
Regards,
Shane.
"PAUL COOPER" <pcooper@wharncliffe.co.uk>
Sent by: ids-bounces@iiug.org
21/07/2006 10:04
Please respond to
ids@iiug.org
To
ids@iiug.org
cc
Subject
Changing data structure forced command termination [7150]
We have a problem with an IBM xSeries server running SCO OpenServer
Enterpise
5.0.5 and Informix Dynamic Server Version 7.30.UC2. When trying to use any
onstat command we get the error "Changing data structure forced command
termination" and when trying to run onmonitor get the error "shmdt: errno
=
22". If we try to select any option in onmonitor we get the error "Unable
to
attach to shared memory".
Aside from this, the informix server is actually running perfectly, the
only
problems I've seen in the Informix log are where it seems to dynamically
assign more shared memory and then round it:
It should be doing this:-
dynamically allocated new shared memory segment (size 8388608)
But it's now doing this:-
dynamically allocated new shared memory segment (size 8388608)
Requested shared memory segment size rounded from 10576KB to 12288KB
dynamically allocated new shared memory segment (size 10829824)
Any assistance would be greatly appreciated.
Regards,
Paul.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Many thanks Keith / Shane, I'll look into your suggestions, it could well be that we only get the problem after more shared memory has been assigned after a re-boot. Onstat not being compatible with the IDS version would also make sense. Thanks again, Paul.