RE: onbar backup problem
Posted in 1999
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting
Hi, there ...
Does the onbar command uses the tempdbs dbspace during the actual backup
process? I asked this because we had the following error message during our
scheduled onbar -b -w backup schedule using Legato Networker 5.1 for UNIX.
ERROR: Unable to get backup data from the database server: ISAM error: no free
disk space.
When I got this message, I noticed that our tempdbs dbspace is almost 100%
full.
Any help would be greatly appreciated.
Thanks!
Edwin M. Manalo
COMCAST Cellular Communications, Inc.
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
manaloe@my-dejanews.com wrote:
>
> Hi, there ...
>
> Does the onbar command uses the tempdbs dbspace during the actual backup
> process? I asked this because we had the following error message during our
> scheduled onbar -b -w backup schedule using Legato Networker 5.1 for UNIX.
>
> ERROR: Unable to get backup data from the database server: ISAM error: no free
> disk space.
>
> When I got this message, I noticed that our tempdbs dbspace is almost 100%
> full.
Yes. Actually it is the archive thread in the engine that is using the
temp space. As pages are modified by various user processes while the
archive is running the Physical Log pre-image of each modified page is
copied into a temp table (one for each dbspace). After each dbspace
is completely written to the archive media the contents of the
corresponding pre-image temp table are dumped to the archive as well.
In 7.3x each of these temp tables is fragmented and spread over all
available dbspaces listed in DBSPACETEMP (do not list non-temporary
dbspaces here during an archive!) and each temp table is dropped after
it has been successfully written to the archive. In 7.2x each temp
table resided in only one of the dbspaces listed in DBSPACETEMP and the
temp tables where created round robin each table in the next dbspace
listed from the last table. Also 7.2x did not drop any of the temp
tables until the entire archive was completed. This could cause one
temp dbspace to fill before the others if several highly active
dbspaces had their temp tables in the same temp dbspace. If you are
running 7.2x add more chunks to the one temp dbspace you have. If you
are running 7.3x add an additional temp dbspace or two; it will improve
sort and archive performance to have at least three tempdbspaces.
Art S. Kagel