RE: ISAM Error when deleting
Posted in 2003
Just for the message list archive,
I solved my problem by droping the indexes and recreating them.
Thanks to everyone that replied my email.
regards
-----Mensaje original-----
De: cyrille_deleruyelle@yahoo.fr [mailto:cyrille_deleruyelle@yahoo.fr]
Enviado el: Jueves, 07 de Agosto de 2003 11:17 a.m.
Para: informix-list@iiug.org
Asunto: Re: ISAM Error when deleting
I think you got a corruption in the partition page corresponding to the
table you were doing the delete on. "key descriptor" : Slot 4 of this page
describes each index keys for the table. More likely, the corruption is
there. First run oncheck -cc/-cDI. Even if it doesn't correct anything,
you'll perhaps be able to drop and recreate the table. If it doesn't work,
call the tech support.
Got a sql error too ?
Francisco Roldan <froldan@5b.com.gt> wrote in message
news:<bgs5h4$g6s$1@terabinaries.xmission.com>...
> Hi everybody,
> I got a problem when deleting from a table.
>
> I got the ISAM Error -103 "illegal key descriptor (too many parts or too
> long) The ISAM processor has been given an invalid key descriptor. For
> C-ISAM programs, review the key descriptor. Each key descriptor has a
> maximum of 8 parts and 120 characters. "
>
> It is a simple delete with one condition on one field (the field is
> part of a not-unique index), and the table doesn't have primary keys.
>
> I don't understand the meaning of "key descriptor".
>
> I would appreciate your help.
>
> Thanks in advance
>
> regards
>
>
> sending to informix-list
sending to informix-list