Re: max number of connections
Posted in 2003
Micha wrote: > I've made a test now - I've started 10 new processes and each has opened a > connection to the database. The effect was immediate - all CONNECT's have > succeeded without any error and the database froze until I've killed them. > Is this supposed to be the documented behaviour? Why are those CONNECTs not > refused with an SQL error message? This is IDS 7.31 on sunos_i386. Your original message said 7.21; this one says 7.31. Which is correct? It's critical because 7.21 is obsolete to the point of being archaic whereas 7.31 is still supported. Assuming it is 7.31, what are the NETTYPE settings you've got, and which connection method are you using? If you had shared memory connections and the nettype limited it to 10, you might run into some problems. It should be of the type 'it takes a minute or more to fail to connect' rather than the DBMS freezing (which would explain why there are no errors in the log file). OTOH, if you're using oltlitcp connections, then you should not run into this problem. If all activity in the DBMS freezes, then this is somewhat different - more likely a bug. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/