Re: onbar/ISM/informix Restore Problem
Posted in 2004
Hi,
there is a detailed description of 'Transferring Data with the Imported
Restore' in 'Informix Storage Manager Administrator's Guide' chapter 5
available at
http://www.ibm.com/software/data/informix/pubs/library/ids_73.html .
In paragraph 'Porting ISM to Your Target Database Server' ISM is initialized
and the devices are added. If the following mount of the storage volumes
fails, then running the command 'ism_catalog -recreate_from <device>' can
solve the problem.
Andreas
Stephen Jones wrote:
> HELP ~ I'm sure I've missed something!
>
> Informix IDS 7.31 UC5
> ISM 2.20 UC1
> Solaris 2.7
>
> I've got two servers, on two different networks, both configured with
> the same host names, OS's, informix installation paths, server numbers
> etc etc.
>
> The first is our live server on our live network, whilst the second is
> our backup server in our backup site, with an ultimate goal to
> replicate our live database via onbar backups and logical logs to the
> backup server. Simple, or so I thought.
>
> I've performed a full system backup on node 1 (onbar -b -w) and copied
> all the files from the ISM devices along with the following files;
> $INFORMIXDIR/etc/ixbar.0
> $ONCONFIG
> $INFORMIXDIR/etc/oncfg_trafic_online.0
> $INFORMIXDIR/etc/sm_versions.std
>
> The devices setup under ISM have been defined with a type of file, and
> show as follows;
> $ ism_show -devices> file disk ISMDiskLogs2 mounted on /trafic/backup/ism/logs, write
> enabled
> file disk ISMDiskData2 mounted on /trafic/backup/ism/backups, write
> enabled
> $ ism_show -volumes> volume pool flags written (%) expires
> ISMDiskData2 ISMDiskData 0 KB 03/16/06
> ISMDiskLogs2 ISMDiskLogs 0 KB 03/16/06
> $
> $ ism_show -volume ISMDiskData2> mminfo: no matches found for the query
> $ ism_show -volume ISMDiskLogs2> mminfo: no matches found for the query
>
> Now the problem!
> I've tried to perform a restore with the 'onbar -r -p -w' command, and
> it always fails with ' 2004-03-16 15:01:47 3698 3697 There are no
> DB/BLOBspaces to backup/restore.'
>
> I've tried setting the informix server up with the same dbspace
> structure, chunks, logical logs settings etc etc, and it's failed.
> I've also tried initialising the instance, and still the same error.
>
> Sorry if it's all a bit muddled, but I've got very confused!