Informix and ASP:
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
We are running Informix OWS 7.3 on SCO OpenServer 5.0. I have installed, Informix CLI (that comes with this on the same CD) on NT server, which is acting as our INTRANET server. I have created a datasource on this server. When I connect my informix database using MS-ACCESS (from same server), it connects and every thing goes ok. BUT, when we try to connect thru web page using ASP, it gives following message: -------------< message starts here >--------- Microsoft OLE DB Provider for ODBC Drivers error '80004005' [INTERSOLV][ODBC Informix driver]Unable to load locale categories. /akulibrary/testing/sajida1/sql/bookq.asp, line 9 -------------< message ends here >--------- Any comments? HELP? we have a dead line to meet. Thanks in advance. Shahid Mehmood Software Designer II Information Systems Department The Aga Khan University Karachi Official:Y
Hi, By default the Informix SetNet writes in the HKEY_CURRENT_USER section of the registry. When you use ASP, the user changes and therefore, the settings become invalid. You should find a program on Informix web site that would make the appropriate changes. It is called regcopy. After running this program your ASP scripts should work fine. Thanks, Imran. -- ===================================================================== Imran Hussain imranh@imranweb.com For FREE Software visit http://www.imranweb.com/freesoft ===================================================================== Shahid Mehmood wrote: > We are running Informix OWS 7.3 on SCO OpenServer 5.0. > > I have installed, Informix CLI (that comes with this on the same CD) on NT > server, which is acting as our INTRANET server. I have created a datasource > on this server. When I connect my informix database using MS-ACCESS (from > same server), it connects and every thing goes ok. > > BUT, when we try to connect thru web page using ASP, it gives following > message: > > -------------< message starts here >--------- > > Microsoft OLE DB Provider for ODBC Drivers error '80004005' > > [INTERSOLV][ODBC Informix driver]Unable to load locale categories. > > /akulibrary/testing/sajida1/sql/bookq.asp, line 9 > > -------------< message ends here >--------- > > Any comments? HELP? we have a dead line to meet. > > Thanks in advance. > > Shahid Mehmood > Software Designer II > Information Systems Department > The Aga Khan University > Karachi > Official:Y