Re: help! Oninit problem...
Posted in 1998
You are absolutely sure that there isn't an existing OnLine instance running
at this point in time ? How about the shared memopry allocation, Informix
may not have freed the necessary segments when it was shut down ?? Try
looking at the shared memory segments (ipcs) and see if any of them are
owned by Informix.
I guess you are trying to run it as Informix with all the necessary
environemnts set ?? (informixdir, path, informixserver, onconfig etc... )
Can you send me a copy of the online.log file immediately from the point of
initialisation please ??
TIA
Sean
lisallee@hotmail.com wrote in message <744vem$tn5$1@nnrp1.dejanews.com>...
>Hi,frineds:
> My informix databse is Online 7.0 running on Sco unix system V
Release
>3.2.This morning I failed on oninit the database,error message in
online.log
>is as the following: Assert Failed:Internal Error-Segmentation
Violation
> who :Session(9,informix@,0,2)
> Thread:(20,xchg_1.2,80414114,1)
> Result:Online must abort Action:Reinitialize shared memory
> See also:/tmp/af.459d0a,shmem.4590a.0
> rsdebug.c,line 3563,thread 20,proc id 365,Segmentation Violation
> Panic:Attempting to bring system downThanks a ton!!
>
>-----------== Posted via Deja News, The Discussion Network ==----------
>http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own