Unable to change locale to Japanese in IDS 9.3
Posted in 2003
Topics: Installation, Setup & Upgrades, Server Administration, Internationalization & Character Sets, Versions, Editions & End-of-Life
Hi,
I am using IDS 9.3 and I need to work with Japanese locale in addition to
the English locale which is default.
When I installed IDS, the locale was English, and in the folder
$INFORMIXDIR/msg folder I see only the folder "en_us". There is a "ja_jp"
folder under $INFORMIXDIR/gls/lc11.
I need to insert Japanese characters into char fields. What are the changes
that I need to do for the environment?
I tried by setting the default locale of my machine to Japanese and also
setting the locale variables, but the dbaccess connection to the database is
still not working. ]
The client and server are on the same machine and I am using Windows 2k.
I am in a fix as to how to proceed.
Thanks for any help in advance.
Regards,
Sumanto
Hi Sumanto,
I am assuming that you are getting "23101: Unable to load locale
categories." when trying to connect to a database if not try this anyway
and respond with the error you are getting/when you are getting it.
To change the default locale of the database, set DB_LOCALE to
ja_jp.sjis-s and bring up the server.
To create a Japanese database set DB_LOCALE ja_jp.sjis-s CLIENT_LOCALE
ja_jp.sjis-s, and create the database.
NOTE: if you create a database with DB_LOCALE=ja_jp.sjis-s then you need
to have DB_LOCALE set to ja_jp.sjis-s to connect to that database.
FYI : to add Japanese localized files to the INFORMIXDIR/msg/ja_jp dir and
to add the utf8 Japanese locale use the international language supplement
(ILS 3.20 or later)
Gerry
"Sumanto Biswas " <SumantoB@InterraIT.COM>
Sent by: forum.subscriber@iiug.org
05/02/2003 09:17 AM
To
ids@iiug.org
cc
Subject
Unable to change locale to Japanese in IDS 9.3 [1071]
Hi,
I am using IDS 9.3 and I need to work with Japanese locale in addition to
the English locale which is default.
When I installed IDS, the locale was English, and in the folder
$INFORMIXDIR/msg folder I see only the folder "en_us". There is a "ja_jp"
folder under $INFORMIXDIR/gls/lc11.
I need to insert Japanese characters into char fields. What are the
changes
that I need to do for the environment?
I tried by setting the default locale of my machine to Japanese and also
setting the locale variables, but the dbaccess connection to the database
is
still not working. ]
The client and server are on the same machine and I am using Windows 2k.
I am in a fix as to how to proceed.
Thanks for any help in advance.
Regards,
Sumanto
Hi Gerry,
I did the steps as mentioned by you, but I am still not able get it working.
Other than that, I also played around with the DBLANG and SERVER_LOCALE, but
I am still not able to get it working. I also tried to work around with the
registry settings for these variables for the server instance.
I am either not able to start the service for the server instances, or while
accessing the database via dbaccess it gives the -23101 error.
Where am I going wrong?
I have already consulted the IDS GLS guide, but I can't make any headway.
My environment is Win2k with Japanese localization with Japanese locales
installed for IDS via ILS 3.30.
Thanks for the help !!
Regards,
Sumanto
-----Original Message-----
From: Gerald Cousins [mailto:gcousins@us.ibm.com]
Sent: Sunday, May 04, 2003 10:58 PM
To: Sumanto Biswas
Cc: ids@iiug.org
Subject: Re: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Sumanto,
I am assuming that you are getting "23101: Unable to load locale
categories." when trying to connect to a database if not try this anyway and
respond with the error you are getting/when you are getting it.
To change the default locale of the database, set DB_LOCALE to ja_jp.sjis-s
and bring up the server.
To create a Japanese database set DB_LOCALE ja_jp.sjis-s CLIENT_LOCALE
ja_jp.sjis-s, and create the database.
NOTE: if you create a database with DB_LOCALE=ja_jp.sjis-s then you need to
have DB_LOCALE set to ja_jp.sjis-s to connect to that database.
FYI : to add Japanese localized files to the INFORMIXDIR/msg/ja_jp dir and
to add the utf8 Japanese locale use the international language supplement
(ILS 3.20 or later)
Gerry
"Sumanto Biswas " <SumantoB@InterraIT.COM>
Sent by: forum.subscriber@iiug.org
05/02/2003 09:17 AM
To
ids@iiug.org
cc
Subject
Unable to change locale to Japanese in IDS 9.3 [1071]
Hi,
I am using IDS 9.3 and I need to work with Japanese locale in addition to
the English locale which is default.
When I installed IDS, the locale was English, and in the folder
$INFORMIXDIR/msg folder I see only the folder "en_us". There is a "ja_jp"
folder under $INFORMIXDIR/gls/lc11.
I need to insert Japanese characters into char fields. What are the changes
that I need to do for the environment?
I tried by setting the default locale of my machine to Japanese and also
setting the locale variables, but the dbaccess connection to the database is
still not working. ]
The client and server are on the same machine and I am using Windows 2k.
I am in a fix as to how to proceed.
Thanks for any help in advance.
Regards,
Sumanto
Hi Sumanto,
You might want to look at this book,
http://www-3.ibm.com/software/data/informix/pubs/library/interim/8332-pdf.html
For the purpose of this test,
unset DB_LOCALE, SERVER_LOCALE, CLIENT_LOCALE, DBLANG and DBNLS, (Do not
set these to empty string, be sure they are not set)
look in $INFORMIXDIR/gls/lc11/ja_jp/ for a file called e01c.lco
if it is not there you might want to install the Japanese locales and the
utf8 conversion files from the ILS.
If you don't have a copy of the ILS temporally copy e01c.lco from the
directory $INFORMIXDIR/gls/lc11/en_us to $INFORMIXDIR/gls/lc11/ja_jp
bring up you server, (This need to be done after copying e01c.lco file, or
installing ILS)
set CLIENT_LOCALE en_us.utf8run the following SQL statements
create database bob;
database sysmaster;
select * from sysdbslocale;
drop database bob;
This lists the locale of each database that you have created.
The row for bob will show the default locale for your server. (as
DB_LOCALE is not set when creating it)
set CLIENT_LOCALE en_us.utf8 (you might want to set this to ja_jp.sjis-sas this would be how you
would normally set CLIENT_LOCALE on a
Japanese windows system)
set DB_LOCALE ja_jp.ujisrun the following SQL statements
create database bob;
database sysmaster;
select * from sysdbslocale where dbs_dbsname='bob';
drop database bob;
This should return
dbs_dbsname bob
dbs_collate ja_JP.57372
If the database you want to access/create is ja_jp.ujis
then DB_LOCLAE should be set to ja_jp.ujis
CLIENT_LOCALE should be compatible.
This requires the following files
$INFORMIXDIR/gls/lc11/en_us/0333.lco (always needed)
$INFORMIXDIR/gls/lc11/ja_jp/e007.lco
$INFORMIXDIR/gls/lc11/ja_jp/xxxx.lco (Where xxxx is determined by
CLIENT_LOCALE)
$INFORMIXDIR/gls/lc11/ll_tt/xxxx.lco (Where xxxx and ll_tt is determined
by CLIENT_LOCALE)
$INFORMIXDIR/gls/cv9/e007xxxx.cvo
$INFORMIXDIR/gls/cv9/xxxxe007.cvo
If CLIENT_LOCALE = ja_jp.ujis then only these files are required
$INFORMIXDIR/gls/lc11/en_us/0333.lco (always needed)
$INFORMIXDIR/gls/lc11/ja_jp/e007.lco
To workout the file names for a locale "ja_jp.ujis" look-up ujis in the
file $INFORMIXDIR/gls/cm3/registry
If you copied the e01c.lco file remove it from the
$INFORMIXDIR/gls/lc11/ja_jp directory.
Good Luck,
Gerry.
Sumanto Biswas <SumantoB@InterraIT.COM>
05/06/2003 06:28 AM
To
Gerald Cousins/Lenexa/IBM@IBMUS
cc
ids@iiug.org
Subject
RE: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Gerry,
I did the steps as mentioned by you, but I am still not able get it
working. Other than that, I also played around with the DBLANG and
SERVER_LOCALE, but I am still not able to get it working. I also tried to
work around with the registry settings for these variables for the server
instance.
I am either not able to start the service for the server instances, or
while accessing the database via dbaccess it gives the -23101 error.
Where am I going wrong?
I have already consulted the IDS GLS guide, but I can't make any headway.
My environment is Win2k with Japanese localization with Japanese locales
installed for IDS via ILS 3.30.
Thanks for the help !!
Regards,
Sumanto
-----Original Message-----
From: Gerald Cousins [mailto:gcousins@us.ibm.com]
Sent: Sunday, May 04, 2003 10:58 PM
To: Sumanto Biswas
Cc: ids@iiug.org
Subject: Re: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Sumanto,
I am assuming that you are getting "23101: Unable to load locale
categories." when trying to connect to a database if not try this anyway
and respond with the error you are getting/when you are getting it.
To change the default locale of the database, set DB_LOCALE to
ja_jp.sjis-s and bring up the server.
To create a Japanese database set DB_LOCALE ja_jp.sjis-s CLIENT_LOCALE
ja_jp.sjis-s, and create the database.
NOTE: if you create a database with DB_LOCALE=ja_jp.sjis-s then you need
to have DB_LOCALE set to ja_jp.sjis-s to connect to that database.
FYI : to add Japanese localized files to the INFORMIXDIR/msg/ja_jp dir and
to add the utf8 Japanese locale use the international language supplement
(ILS 3.20 or later)
Gerry
"Sumanto Biswas " <SumantoB@InterraIT.COM>
Sent by: forum.subscriber@iiug.org
05/02/2003 09:17 AM
To
ids@iiug.org
cc
Subject
Unable to change locale to Japanese in IDS 9.3 [1071]
Hi,
I am using IDS 9.3 and I need to work with Japanese locale in addition to
the English locale which is default.
When I installed IDS, the locale was English, and in the folder
$INFORMIXDIR/msg folder I see only the folder "en_us". There is a "ja_jp"
folder under $INFORMIXDIR/gls/lc11.
I need to insert Japanese characters into char fields. What are the
changes
that I need to do for the environment?
I tried by setting the default locale of my machine to Japanese and also
setting the locale variables, but the dbaccess connection to the database
is
still not working. ]
The client and server are on the same machine and I am using Windows 2k.
I am in a fix as to how to proceed.
Thanks for any help in advance.
Regards,
Sumanto
Hi Gerry,
Thanks a lot for the detailed help. I was able to get it working with the
information you sent.
It was much more clearer then the documentation :-)
Thanks again,
Sumanto
-----Original Message-----
From: Gerald Cousins [mailto:gcousins@us.ibm.com]
Sent: Wednesday, May 07, 2003 12:35 AM
To: Sumanto Biswas
Cc: ids@iiug.org
Subject: RE: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Sumanto,
You might want to look at this book,
http://www-3.ibm.com/software/data/informix/pubs/library/interim/8332-pdf.ht
ml
For the purpose of this test,
unset DB_LOCALE, SERVER_LOCALE, CLIENT_LOCALE, DBLANG and DBNLS, (Do not set
these to empty string, be sure they are not set)
look in $INFORMIXDIR/gls/lc11/ja_jp/ for a file called e01c.lco
if it is not there you might want to install the Japanese locales and the
utf8 conversion files from the ILS.
If you don't have a copy of the ILS temporally copy e01c.lco from the
directory $INFORMIXDIR/gls/lc11/en_us to $INFORMIXDIR/gls/lc11/ja_jp
bring up you server, (This need to be done after copying e01c.lco file, or
installing ILS)
set CLIENT_LOCALE en_us.utf8run the following SQL statements
create database bob;
database sysmaster;
select * from sysdbslocale;
drop database bob;
This lists the locale of each database that you have created.
The row for bob will show the default locale for your server. (as DB_LOCALE
is not set when creating it)
set CLIENT_LOCALE en_us.utf8 (you might want to set this to ja_jp.sjis-s asthis would be how you
would normally set CLIENT_LOCALE on a
Japanese windows system)
set DB_LOCALE ja_jp.ujisrun the following SQL statements
create database bob;
database sysmaster;
select * from sysdbslocale where dbs_dbsname='bob';
drop database bob;
This should return
dbs_dbsname bob
dbs_collate ja_JP.57372
If the database you want to access/create is ja_jp.ujis
then DB_LOCLAE should be set to ja_jp.ujis
CLIENT_LOCALE should be compatible.
This requires the following files
$INFORMIXDIR/gls/lc11/en_us/0333.lco (always needed)
$INFORMIXDIR/gls/lc11/ja_jp/e007.lco
$INFORMIXDIR/gls/lc11/ja_jp/xxxx.lco (Where xxxx is determined by
CLIENT_LOCALE)
$INFORMIXDIR/gls/lc11/ll_tt/xxxx.lco (Where xxxx and ll_tt is determined by
CLIENT_LOCALE)
$INFORMIXDIR/gls/cv9/e007xxxx.cvo
$INFORMIXDIR/gls/cv9/xxxxe007.cvo
If CLIENT_LOCALE = ja_jp.ujis then only these files are required
$INFORMIXDIR/gls/lc11/en_us/0333.lco (always needed)
$INFORMIXDIR/gls/lc11/ja_jp/e007.lco
To workout the file names for a locale "ja_jp.ujis" look-up ujis in the file
$INFORMIXDIR/gls/cm3/registry
If you copied the e01c.lco file remove it from the
$INFORMIXDIR/gls/lc11/ja_jp directory.
Good Luck,
Gerry.
Sumanto Biswas <SumantoB@InterraIT.COM>
05/06/2003 06:28 AM
To
Gerald Cousins/Lenexa/IBM@IBMUS
cc
ids@iiug.org
Subject
RE: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Gerry,
I did the steps as mentioned by you, but I am still not able get it working.
Other than that, I also played around with the DBLANG and SERVER_LOCALE, but
I am still not able to get it working. I also tried to work around with the
registry settings for these variables for the server instance.
I am either not able to start the service for the server instances, or while
accessing the database via dbaccess it gives the -23101 error.
Where am I going wrong?
I have already consulted the IDS GLS guide, but I can't make any headway.
My environment is Win2k with Japanese localization with Japanese locales
installed for IDS via ILS 3.30.
Thanks for the help !!
Regards,
Sumanto
-----Original Message-----
From: Gerald Cousins [mailto:gcousins@us.ibm.com]
Sent: Sunday, May 04, 2003 10:58 PM
To: Sumanto Biswas
Cc: ids@iiug.org
Subject: Re: Unable to change locale to Japanese in IDS 9.3 [1071]
Hi Sumanto,
I am assuming that you are getting "23101: Unable to load locale
categories." when trying to connect to a database if not try this anyway and
respond with the error you are getting/when you are getting it.
To change the default locale of the database, set DB_LOCALE to ja_jp.sjis-s
and bring up the server.
To create a Japanese database set DB_LOCALE ja_jp.sjis-s CLIENT_LOCALE
ja_jp.sjis-s, and create the database.
NOTE: if you create a database with DB_LOCALE=ja_jp.sjis-s then you need to
have DB_LOCALE set to ja_jp.sjis-s to connect to that database.
FYI : to add Japanese localized files to the INFORMIXDIR/msg/ja_jp dir and
to add the utf8 Japanese locale use the international language supplement
(ILS 3.20 or later)
Gerry
"Sumanto Biswas " <SumantoB@InterraIT.COM>
Sent by: forum.subscriber@iiug.org
05/02/2003 09:17 AM
To
ids@iiug.org
cc
Subject
Unable to change locale to Japanese in IDS 9.3 [1071]
Hi,
I am using IDS 9.3 and I need to work with Japanese locale in addition to
the English locale which is default.
When I installed IDS, the locale was English, and in the folder
$INFORMIXDIR/msg folder I see only the folder "en_us". There is a "ja_jp"
folder under $INFORMIXDIR/gls/lc11.
I need to insert Japanese characters into char fields. What are the changes
that I need to do for the environment?
I tried by setting the default locale of my machine to Japanese and also
setting the locale variables, but the dbaccess connection to the database is
still not working. ]
The client and server are on the same machine and I am using Windows 2k.
I am in a fix as to how to proceed.
Thanks for any help in advance.
Regards,
Sumanto