RE: Archive on disk
Posted in 1999
Topics: Server Administration, Platform-Specific Issues, Versions, Editions & End-of-Life
Paulo,
The problem is with the ulimit (man ulimit).
On AIX the default largest file size that a
user can create is about 1Gb. You need to ask
your System Administrator to increase the
ulimit using smitty. If I recall correclty
there are two values that need to be
changed: Hard File Size Limit, and
Soft File Size Limit
HTH
Tino
> -----Original Message-----
> From: owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org]On Behalf Of Paulo Amorim
> Sent: Thursday, November 04, 1999 8:01 AM
> To: informix-list@iiug.org
> Subject: Archive on disk
>
>
> Hello
>
> I'm running IDS 7.30 on a IBM F50 - AIX 4.3.2.
>
> We're trying to make a full archive on disk, but it stops at 50% with
> the following error message:
> Backup failed - error number 32 (dd write error)
>
> The file generated by the archive doesn't go up to the limit of
> 1.073.741.312 bytes, when the error occurs. The file has permissions
> 660 and group and owner Informix.
>
> Can anybody help me with this problem ???? I'm sure that the problem
> was not space available on disk (There was enough room, really).
>
> These are the onconfig parameters for TAPEDEV:
>
> TAPEDEV /usr/informix/archive_dsk # Tape device path
> TAPEBLK 512 # Tape block size (Kbytes)
> TAPESIZE 2000000 # Maximum amount of data to put on tape
> (Kbytes)>
> Thanks in advance.
>
> --
> Paulo Roberto Marelli de Amorim
> TS&0 Consulting
> Brasil
>
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
There are multiple restrictions involved here;
- As previously noted, the default "hard limit" for filesize on
AIX is 2097151 512-byte blocks, which is:
2097151 * 512 / 1024 / 1024 == 1GB
(See /etc/security/limits)
But, Informix oninit runs "suid", so these restrictions don't apply.
- You can raise the limit for user informix, but you will
run into another limit ... 2GB filesize limit, imposed by
the signed 32-bit "seek" value.
- AIX supports "large files" using 64-bit seek values, and you
must enable this when you create the filesystem.
smitty jfs
Add a Large File Enabled Journaled File System
- Prior to Informix release 7.31.UC1, Informix was internally
enforcing a ulimit filesize of 2GB. With Informix fix 76256,
this was changed to "unlimited", and large file dump testing
has completed successfully.
Aside regarding dumps to tape:
- The default Informix blocksize recommendation for tapes is
documented as 512. This will waste a great deal of tape,
and should be changed to 1024. The SCSI tape hardware
writes in 1K blocks. See:
http://www.rs6000.ibm.com/doc_link/en_US/a_doc_lib/aixbman/baseadmn/tape_attr.htm#A4B8F1D378virg
Tino Cremidis wrote:
>
> Paulo,
>
> The problem is with the ulimit (man ulimit).
> On AIX the default largest file size that a
> user can create is about 1Gb. You need to ask
> your System Administrator to increase the
> ulimit using smitty. If I recall correclty
> there are two values that need to be
> changed: Hard File Size Limit, and
> Soft File Size Limit
>
> HTH
>
> Tino
>
> > -----Original Message-----
> > From: owner-informix-list@iiug.org
> > [mailto:owner-informix-list@iiug.org]On Behalf Of Paulo Amorim
> > Sent: Thursday, November 04, 1999 8:01 AM
> > To: informix-list@iiug.org
> > Subject: Archive on disk
> >
> >
> > Hello
> >
> > I´m running IDS 7.30 on a IBM F50 - AIX 4.3.2.
> >
> > We´re trying to make a full archive on disk, but it stops at 50% with
> > the following error message:
> > Backup failed - error number 32 (dd write error)
> >
> > The file generated by the archive doesn´t go up to the limit of
> > 1.073.741.312 bytes, when the error occurs. The file has permissions
> > 660 and group and owner Informix.
> >
> > Can anybody help me with this problem ???? I´m sure that the problem
> > was not space available on disk (There was enough room, really).
> >
> > These are the onconfig parameters for TAPEDEV:
> >
> > TAPEDEV /usr/informix/archive_dsk # Tape device path
> > TAPEBLK 512 # Tape block size (Kbytes)
> > TAPESIZE 2000000 # Maximum amount of data to put on tape
> > (Kbytes)
Dick Dunbar wrote: [SNIP] > Aside regarding dumps to tape: > > - The default Informix blocksize recommendation for tapes is > documented as 512. This will waste a great deal of tape, > and should be changed to 1024. The SCSI tape hardware > writes in 1K blocks. See: [SNIP] Note that the TAPEBLK and LTAPEBLK specify the tape blocksize in KB NOT bytes so a recommended TAPEBLK of 512 is (512*1024) so there is no wasting of tape due to this recommendation. It SHOULD be noted though that some tape sub-systems either cannot or do not write block that large to tape. For example, on DGUX any blocksize greater than 256K is cached in the tape driver and restructured into 256K blocks, other OS's cannot handle block sized greater than some value, say 32K of 128K or even 1024K, and will return an error if you try larger blocks. Art S. Kagel