Recovery: Who got rolled back
Posted in 2004
We had an error in our AIX shutdown procedures and the Informix
instance was not being shut down cleanly prior to a system reboot.
When started again, the recovery processes indicated that transactions
were rolled back. but didn't say which one's.
Since the reboot occures during off hours very few people were
actually connected. I've used onlog to examine the log at the time of
recovery and only see completed transactions (ie, begin, work, commit)
at the time.
Is there a way to determine what transactions were rolled back?
PS. Why doesn't Informix put some sort of marker in the transaction
log indicating that the instance started? You can sort of figure this
out by a checkpoint record, but that might be one of several during
that time period.