RE: Gripe-- Bad SQL syntax can crash server. And... PA still st
Posted in 2004
Topics: General Discussion
The syntax bug on an old version notwithstanding, please let us know what your experiences are after dealing with "O" support for the first time. I'll bet that you'll wish you were back here. Just my $0.02 USD. -Dave -----Original Message----- From: David E. Grove [mailto:david_grove@correct.state.ak.us] Sent: Wednesday, May 12, 2004 3:51 PM To: informix-list@iiug.org Subject: Gripe-- Bad SQL syntax can crash server. And... PA still stinks. 9.21.FC4 Solaris 8 Sun E3500 I just had an exciting morning. The production server crashed (an assert failure). Turned out someone had executed an ad hoc query, containing syntax error: "SELECT col (DISTINCT) FROM table". Tech support confirms (Bug 135015) that bad SQL syntax crashes engine. Reproducible in "stores" database. The solution is not to execute bad syntax SQL! I was totally shocked and amazed that bad SQL syntax could immediately bring the engine offline. I'm even more surprised that there was no patch. Since 9.21 is imminently EOL, I know it is not practical to expect a fix now, but it seems that this bug was already known, before I experienced it this morning. In addition, my initial call for tech support was rejected because we "didn't have IDS under support". We had switched to IBM DM Gold (shows on our Passport Advantage site) about 6 months ago. We persisted, and spoke with a customer service rep, who confirmed that our agency actually is a customer, gave us a case #, and connected us back with tech support. I was told that tech support doesn't always have access to information about DM Gold customers. They didn't seem to understand why I felt that it was unacceptable for IBM to fail to recognize us as a customer. They seemed to think we should just be happy that, through manual intervention, we were able to secure tech support at all. It is continuing experiences such as this that cause me to not have feelings of regret concerning our agency's decision to bOldly gO tO, shall we say, the Other side. Our IBM experience has been somewhat less than satisfying. It may be possible that there conceivably is a reason why traffic at cdi might seem like it may be decreasing. Subjunctively speaking, of course. :-) -- David Grove - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - "I think not," said Descartes, and disappeared. sending to informix-list
Our agency has no experience with with either the product or support of <insert-O-word-here>, so we are taking a major decision, but, weighing all, decided it was worth the risk. I don't want to leave the impression that the particular incident I described caused us to change. That decision was made months ago, based on cummulative perceptions (over about 1 1/2 years) of support and licensing issues. I guess we'll find out soon enough whether the "grass is greener". DG "David Buchholz" <David.Buchholz@vitalps.com> wrote in message news:c801b5$hap$1@terabinaries.xmission.com... > > The syntax bug on an old version notwithstanding, please let us know what > your experiences are after dealing with "O" support for the first time. > I'll bet that you'll wish you were back here. Just my $0.02 USD. > > -Dave > > -----Original Message----- > From: David E. Grove [mailto:david_grove@correct.state.ak.us] > Sent: Wednesday, May 12, 2004 3:51 PM > To: informix-list@iiug.org > Subject: Gripe-- Bad SQL syntax can crash server. And... PA still > stinks. > > > 9.21.FC4 > Solaris 8 > Sun E3500 > > > I just had an exciting morning. > > The production server crashed (an assert failure). Turned out someone had > executed an ad hoc query, containing syntax error: "SELECT col (DISTINCT) > FROM table". Tech support confirms (Bug 135015) that bad SQL syntax > crashes engine. Reproducible in "stores" database. > > The solution is not to execute bad syntax SQL! > > I was totally shocked and amazed that bad SQL syntax could immediately bring > the engine offline. I'm even more surprised that there was no patch. Since > 9.21 is imminently EOL, I know it is not practical to expect a fix now, but > it seems that this bug was already known, before I experienced it this > morning. > > In addition, my initial call for tech support was rejected because we > "didn't have IDS under support". We had switched to IBM DM Gold (shows on > our Passport Advantage site) about 6 months ago. We persisted, and spoke > with a customer service rep, who confirmed that our agency actually is a > customer, gave us a case #, and connected us back with tech support. I was > told that tech support doesn't always have access to information about DM > Gold customers. > > They didn't seem to understand why I felt that it was unacceptable for IBM > to fail to recognize us as a customer. They seemed to think we should just > be happy that, through manual intervention, we were able to secure tech > support at all. > > It is continuing experiences such as this that cause me to not have feelings > of regret concerning our agency's decision to bOldly gO tO, shall we say, > the Other side. > > Our IBM experience has been somewhat less than satisfying. > > It may be possible that there conceivably is a reason why traffic at cdi > might seem like it may be decreasing. Subjunctively speaking, of course. > :-) > > > > -- > David Grove > > - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - > "I think not," said Descartes, and disappeared. > > > sending to informix-list
In the interest of completeness, I should also add that changing enterprise standards (applicable to all State of Alaska Departments and agencies) also played a significant role in our decision. "David Buchholz" <David.Buchholz@vitalps.com> wrote in message news:c801b5$hap$1@terabinaries.xmission.com... > > The syntax bug on an old version notwithstanding, please let us know what > your experiences are after dealing with "O" support for the first time. > I'll bet that you'll wish you were back here. Just my $0.02 USD. > > -Dave > > -----Original Message----- > From: David E. Grove [mailto:david_grove@correct.state.ak.us] > Sent: Wednesday, May 12, 2004 3:51 PM > To: informix-list@iiug.org > Subject: Gripe-- Bad SQL syntax can crash server. And... PA still > stinks. > > > 9.21.FC4 > Solaris 8 > Sun E3500 > > > I just had an exciting morning. > > The production server crashed (an assert failure). Turned out someone had > executed an ad hoc query, containing syntax error: "SELECT col (DISTINCT) > FROM table". Tech support confirms (Bug 135015) that bad SQL syntax > crashes engine. Reproducible in "stores" database. > > The solution is not to execute bad syntax SQL! > > I was totally shocked and amazed that bad SQL syntax could immediately bring > the engine offline. I'm even more surprised that there was no patch. Since > 9.21 is imminently EOL, I know it is not practical to expect a fix now, but > it seems that this bug was already known, before I experienced it this > morning. > > In addition, my initial call for tech support was rejected because we > "didn't have IDS under support". We had switched to IBM DM Gold (shows on > our Passport Advantage site) about 6 months ago. We persisted, and spoke > with a customer service rep, who confirmed that our agency actually is a > customer, gave us a case #, and connected us back with tech support. I was > told that tech support doesn't always have access to information about DM > Gold customers. > > They didn't seem to understand why I felt that it was unacceptable for IBM > to fail to recognize us as a customer. They seemed to think we should just > be happy that, through manual intervention, we were able to secure tech > support at all. > > It is continuing experiences such as this that cause me to not have feelings > of regret concerning our agency's decision to bOldly gO tO, shall we say, > the Other side. > > Our IBM experience has been somewhat less than satisfying. > > It may be possible that there conceivably is a reason why traffic at cdi > might seem like it may be decreasing. Subjunctively speaking, of course. > :-) > > > > -- > David Grove > > - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - > "I think not," said Descartes, and disappeared. > > > sending to informix-list