Re: Error occurs when oninit: DBSERVERNAME 'sharp' not in sqlhosts file.
Posted in 2006
lovecreatesbeauty wrote:
> None wrote:
>> The machine is restarted but Informix does not come up automatically. I
>> use oninit without options to bring Informix database server online. I
>> get an error message then as following, how can I do with it? Can I
>> edit the sqlhosts file manually and add an entry to correct the error?
>> Thank you.
>>
>> $ su root -c './ids_hp/bin/oninit'
>> Password:>> oninit: DBSERVERNAME 'sharp' not in sqlhosts file or sqlhosts file
>> contents
>> are damaged.
>> $
>
> The content of the file ./ids_hp/etc/sqlhosts is:
>
> [snip]
>
> thbs onsoctcp sharp inf_thbs
> #cssdev onsoctcp sharp cssdev
> #csspat onsoctcp sharp inf_csspat> citpatsoc onsoctcp sharp citpatsoc s=0
> citpat onsoctcp sharp citpat s=0
> #citpatshm onipcshm sharp citpatshm
>
> spvjt_sharp onsoctcp sharp spvjt_sharp
> spvjt_sharpshm onipcshm sharp spvjt_sharpshm
> spvjt_sharpsoc onsoctcp sharp spvjt_sharpsoc
>
> jt_enable onsoctcp sharp jt_enable
> jt_enableshm onipcshm sharp jt_enableshm
> jt_enablesoc onsoctcp sharp jt_enablesoc
>
> css_enable onsoctcp sharp css_enable
> css_enableshm onipcshm sharp css_enableshm
> css_enablesoc onsoctcp sharp css_enablesoc>
In $INFORMIXDIR/etc/$ONCONFIG you have DBSERVERNAME set to 'sharp',
which according to your sqlhosts file, is the name of your host.
DBSERVERNAME (and any DBSERVERALIASES) should match with the first
column in sqlhosts.
--
rh