r4gl/isql FAILS AFTER IDS 10.0 INSTALLATION
Posted in 2005
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET, Connectivity: ESQL/C, 4GL & Embedded SQL, Licensing & Editions, Platform-Specific Issues, Java & JDBC Development, Versions, Editions & End-of-Life
After the installation of IDS 10.00 Server (thru ids_install installation script), informix tools such as r4gl, isql etc fail to invoke by giving error "The module has an invalid magic number". The error message are as follows : % r4gl exec(): 0509-036 Cannot load program r4gl because of the following errors: 0509-150 Dependent module /u2/informix/lib/esql/libifsql.so could not be loaded. 0509-103 The module has an invalid magic number. % Before the installation of IDS Server, these products were running alright. I have installed the following products in the order in which they are listed below: 1. Informix Interactive Debugger V7.32 2. Informix RDS run time V7.32 3. Informix SQL V7.32 4. Informix RDS Development V7.32 5. IDS 10.0 Workgroup Edition Server along with (IConnect & JDBC drivers) Our enviroment is AIX 5L (5.3 64 bit kernel) on IBM pSeries 520 HW (dual proc.) It will be appreciated if anyone can help me to identify the cause of this error. Thanks.
You need to have in mind the installation order of products. Do you install IDS 10 only? I think you need to install in order ISQL 4GL-RDS (You don't need the runtime for development) 4GL-Debugger IDS10 Conectivity products. That works for me. J. Reghunadh P.... escribió: > After the installation of IDS 10.00 Server (thru ids_install installation script), informix tools such as r4gl, isql etc fail to invoke by giving error "The module has an invalid magic number". The error message are as follows : > > % r4gl > exec(): 0509-036 Cannot load program r4gl because of the following errors: > 0509-150 Dependent module /u2/informix/lib/esql/libifsql.so could not be loaded. > 0509-103 The module has an invalid magic number. > % > > Before the installation of IDS Server, these products were running alright. I have installed the following products in the order in which they are listed below: > > 1. Informix Interactive Debugger V7.32 > 2. Informix RDS run time V7.32 > 3. Informix SQL V7.32 > 4. Informix RDS Development V7.32 > 5. IDS 10.0 Workgroup Edition Server along with (IConnect & JDBC drivers) > > Our enviroment is AIX 5L (5.3 64 bit kernel) on IBM pSeries 520 HW (dual proc.) > > It will be appreciated if anyone can help me to identify the cause of this error. > Thanks. > > > >
Hi Mr.Jean, First, let me thank u for your kind attention on to our problem. The problem still exists, even after doing a reinstallation of all the products in the order suggested by you. Also the installation of Informix Debugger failed during this time by giving the following message : % Installing directory . Installing directory bin Installing directory lib Installing directory lib/esql etc/brand: Cannot open lib/esql/igens09a.so Installation of IBM INFORMIX-4GL Interactive Debugger failed. % Can u please suggest any other work-arounds ? Thanks.
What is the version of informix products with full extension? Are you mixing 32 and 64 bit products? --- "Reghunadh P...." <reghu_nadh@hotmail.com> wrote: > After the installation of IDS 10.00 Server (thru > ids_install installation script), informix tools > such as r4gl, isql etc fail to invoke by giving > error "The module has an invalid magic number". The > error message are as follows : > > % r4gl > exec(): 0509-036 Cannot load program r4gl because > of the following errors: > 0509-150 Dependent module > /u2/informix/lib/esql/libifsql.so could not be > loaded. > 0509-103 The module has an invalid magic > number. > % > > Before the installation of IDS Server, these > products were running alright. I have installed the > following products in the order in which they are > listed below: > > 1. Informix Interactive Debugger V7.32 > 2. Informix RDS run time V7.32 > 3. Informix SQL V7.32 > 4. Informix RDS Development V7.32 > 5. IDS 10.0 Workgroup Edition Server along with > (IConnect & JDBC drivers) > > Our enviroment is AIX 5L (5.3 64 bit kernel) on IBM > pSeries 520 HW (dual proc.) > > It will be appreciated if anyone can help me to > identify the cause of this error. > Thanks. > > > > ____________________________________________________ Start your day with Yahoo! - make it your home page http://www.yahoo.com/r/hs
Hi Mr.Agrawal, The problem has been solved with the help of Informix Tech Support guys from U.K. (esp. Mr.Junaid Ali). And it was the same matter (mix up of 32 bit & 64 bit media) as you thought. Thank u so much for ur kind attention.