ONSOCTCP AND LINUX
Posted in 1999
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Transactions, Locking & Isolation, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
I have IDS for linux 7.3 and I have installed it on redhat 2.0.36. I
have configured sqlhosts and the onconfig file. I have downloaded and
installed all the file descriptor patches.
I cannot get the onsoctcp connection to my database server to work. As
a matter of fact, I cannot initialize the database while there is a
DBSERVERALIAS and NETTYP entry for my onsoctcp protocal in the onconfig
file. Someone told me that to get this to work, I have to download
some NET patches. Where are they ?
Here is what happens ...
oninit -i fails with this message:
bsd_nsf_sendfd: sendmsg error - spipe 0, fd 4, error 22
********* bsd_nsf_flush: pid = 440 spipe = 0 errno = 22 ******
online.log contains the following
(note that my date is set 1 year in advance)
Sat Aug 19 14:27:42 2000
14:27:42 Event alarms enabled. ALARMPROG =
'/opt/informix/etc/log_full.sh'
14:27:48 DR: DRAUTO is 0 (Off)
14:27:49 Informix Dynamic Server Version 7.30.U Software SerialNumber AAC#J624843
14:27:49 Assert Failed: nsfpipe.c, line 2096, thread 9, errno=22, spipe
error.
14:27:49 Informix Dynamic Server Version 7.30.U
14:27:49 Who: Session(3, root@, 0, 0)
Thread(9, soctcppoll, 0, 8)
File: called by ASF mt_affail Line: 0
14:27:51 Informix Dynamic Server Initialized -- Complete DiskInitialized.
14:27:51 Warning: Invalid dbspace 'tempdb1' listed in DBSPACETEMP.
(I have created DBSPACETEMP in onmonitor, why do I still get this
message ?)
14:27:51 Checkpoint Completed: duration was 0 seconds.
14:27:51 Dataskip is now OFF for all dbspaces
14:27:51 On-Line Mode
14:27:51 Building 'sysmaster' database ...
14:27:52 See Also: /tmp/af.9fbd4, shmem.9fbd4.0
14:27:53 nsfpipe.c, line 2096, thread 9, errno=22, spipe error.
14:27:53 PANIC: Attempting to bring system down
my console log reads:
Assertion Failure Type:\\t\\c
FAILURE
Host Name:\\t\\tpeord.uscourts.gov
Database Server Name:\\tbatangas
Time of failure:\\t\\c
Sat Aug 19 14:27:49 PDT 2000
AF file:\\t\\t/tmp/af.9fbd4
Shared memory file:\\tNone
System Blocking:\\t\\c
OFF
my database server name is batanagas .
My sqlhosts entries are: (is this right ?)
batangas_tcp onsoctcp peord batangas_tcp
batangas onipcshm peord batangas_shm
my environment variables are
INFORMIXDIR='/opt/informix'
INFORMIXSERVER='batangas'
ONCONFIG='onconfig'
the onconfig entries in question are shown here
DBSERVERNAME batangas # Name of default database server
DBSERVERALIASES batangas_tcp # List of alternate dbservernames
NETTYPE soctcp,1,100,NET # Configure poll thread(s) for nettype
NETTYPE ipcshm,1,100,CPU # Configure poll thread(s) for nettype
I can initialize the database if I comment out these lines from onconfig
DBSERVERALIASES batangas_tcp
NETTYPE soctcp,1,100,net
My entire onconfig file follows
#**************************************************************************
#
# INFORMIX SOFTWARE, INC.
#
# Title: onconfig.std
# Description: Informix Dynamic Server Configuration Parameters
#
#**************************************************************************
# Root Dbspace Configuration
ROOTNAME rootdbs # Root dbspace name
ROOTPATH /db/file.db # Path for device containing rootdbspace
ROOTOFFSET 0 # Offset of root dbspace into device
(Kbytes)
ROOTSIZE 20000 # Size of root dbspace (Kbytes)
# Disk Mirroring Configuration Parameters
MIRROR 0 # Mirroring flag (Yes = 1, No = 0)
MIRRORPATH # Path for device containing mirroredroot
MIRROROFFSET 0 # Offset into mirrored device (Kbytes)
# Physical Log Configuration
PHYSDBS rootdbs # Location (dbspace) of physical log
PHYSFILE 1000 # Physical log file size (Kbytes)
# Logical Log Configuration
LOGFILES 6 # Number of logical log files
LOGSIZE 500 # Logical log size (Kbytes)
# Diagnostics
MSGPATH /opt/informix/online.log # System message log file path
CONSOLE /dev/console # System console message path
ALARMPROGRAM /opt/informix/etc/log_full.sh # Alarm program pathSYSALARMPROGRAM /opt/informix/etc/evidence.sh # System Alarm program
path
TBLSPACE_STATS 1
# System Archive Tape Device
TAPEDEV /dev/null # Tape device path
TAPEBLK 16 # Tape block size (Kbytes)
TAPESIZE 10240 # Maximum amount of data to put on tape
(Kbytes)
# Log Archive Tape Device
LTAPEDEV /dev/null # Log tape device path
LTAPEBLK 16 # Log tape block size (Kbytes)
LTAPESIZE 10240 # Max amount of data to put on log tape
(Kbytes)
# Optical
STAGEBLOB # Informix Dynamic Server/Optical
staging area
# System Configuration
SERVERNUM 9 # Unique id corresponding to a DynamicServer instance
DBSERVERNAME batangas # Name of default database serverDBSERVERALIASES batangas_tcp List of alternate dbservernames
NETTYPE soctcp,1,100,NET # Configure poll thread(s) for nettype
NETTYPE ipcshm,1,100,CPU # Configure poll thread(s) for nettype
DEADLOCK_TIMEOUT 60 # Max time to wait of lock indistributed env.
RESIDENT 1 # Forced residency flag (Yes = 1, No =
0)
MULTIPROCESSOR 0 # 0 for single-processor, 1 formulti-processor
NUMCPUVPS 1 # Number of user (cpu) vps
SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vpsto one
NOAGE 0 # Process aging
AFF_SPROC 0 # Affinity start processor
AFF_NPROCS 0 # Affinity number of processors
# Shared Memory Parameters
LOCKS 2000 # Maximum number of locks
BUFFERS 200 # Maximum number of shared buffers
NUMAIOVPS # Number of IO vps
PHYSBUFF 32 # Physical log buffer size (Kbytes)
LOGBUFF 32 # Logical log buffer size (Kbytes)LOGSMAX 6 # Maximum number of logical log files
CLEANERS 1 # Number of buffer cleaner processes
SHMBASE 0x10000000 # Shared memory base address
SHMVIRTSIZE 8000 # initial virtual shared memory segmentsize
SHMADD 8192 # Size of new shared memory segments
(Kbytes)
SHMTOTAL 0 # Total shared memory (Kbytes).
0=>unlimited
CKPTINTVL 300 # Check point interval (in sec)
LRUS 8 # Number of LRU queues
LRU_MAX_DIRTY 60 # LRU percent dirty begin cleaning limit
LRU_MIN_DIRTY 50 # LRU percent dirty end cleaning limit
LTXHWM 50 # Long transaction high water markpercentage
LTXEHWM 60
In article <37BC796B.E323ADED@jps.net>, dja7 <dja7@jps.net> wrote: >I have IDS for linux 7.3 and I have installed it on redhat 2.0.36. I >have configured sqlhosts and the onconfig file. I have downloaded and >installed all the file descriptor patches. > >I cannot get the onsoctcp connection to my database server to work. Are you running the current 7.30.UC7 release?