uncompress fails
Posted in 2009
Topics: Storage & Space Management, Server Administration, Transactions, Locking & Isolation, Platform-Specific Issues
Hi all,
IDS 11.50.FC4 on Solaris 10.
For reverting back my test instance from 11.50.FC4 to 11.10 using "onmode -b
11.10" i have to uncompress all the tables those i had compressed, shrink and
repack.
Out of 106 tables those i tried to uncompress the following command fails for
2 tables with the error in message log:
EXECUTE FUNCTION task("table uncompress", "rvleist", "test", "informix");(expression) FAILED: table uncompress test:informix.rvleist
09:33:15 SCHAPI Uncompress for test:informix.rvleist started
09:33:15 Uncompress operation failed for test:informix.rvleist, iserrno 0
09:33:15 SCHAPI ERROR: table uncompress test:informix.rvleist failed
I had also tried doing it offline but with no success:
EXECUTE FUNCTION admin("table uncompress_offline", "rvleist", "test","informix");
expression
-474
I dont understand what -474 is trying to tell me :(
onstat -pt test:rvleist
TBLspace Flags 8000802 Row Locking
TBLspace use 4 bit bit-maps
TBLspace is compressed
No changes had been made to the schema of the table after compression.
What could be the possible reasons for failing to uncompress the 2 tables?
Should i try uncompressing it by partnum?
Any Help is appreciated!
Regards
Vikas
is it possible that there is not enough free space in the dbspace for the
uncompressed copy of the table?
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Tue, Aug 4, 2009 at 3:41 AM, VIKAS HIVARKAR <vikas.hivarkar@gmail.com>wrote:
> Hi all,
>
> IDS 11.50.FC4 on Solaris 10.
>
> For reverting back my test instance from 11.50.FC4 to 11.10 using "onmode
> -b
> 11.10" i have to uncompress all the tables those i had compressed, shrink
> and
> repack.
>
> Out of 106 tables those i tried to uncompress the following command fails
> for
> 2 tables with the error in message log:
>
> EXECUTE FUNCTION task("table uncompress", "rvleist", "test", "informix");> (expression) FAILED: table uncompress test:informix.rvleist
>
> 09:33:15 SCHAPI Uncompress for test:informix.rvleist started
> 09:33:15 Uncompress operation failed for test:informix.rvleist, iserrno 0
> 09:33:15 SCHAPI ERROR: table uncompress test:informix.rvleist failed
>
> I had also tried doing it offline but with no success:
>
> EXECUTE FUNCTION admin("table uncompress_offline", "rvleist", "test",> "informix");
>
> expression
> -474
>
> I dont understand what -474 is trying to tell me :(
>
> onstat -pt test:rvleist>
> TBLspace Flags 8000802 Row Locking
>
> TBLspace use 4 bit bit-maps
>
> TBLspace is compressed
>
> No changes had been made to the schema of the table after compression.
>
> What could be the possible reasons for failing to uncompress the 2 tables?
>
> Should i try uncompressing it by partnum?
>
> Any Help is appreciated!
>
> Regards
> Vikas
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5c2f1ceabaf047052fba8
> uncompress fails [16577]
>
> VIKAS HIVARKAR
>
> to:
>
> ids
>
> 08/04/2009 10:49 AM
>
> Sent by:
>
> ids-bounces@iiug.org]
>
> Please respond to ids
>
> Hi all,
>
> IDS 11.50.FC4 on Solaris 10.
>
> For reverting back my test instance from 11.50.FC4 to 11.10 using "onmode
-b
> 11.10" i have to uncompress all the tables those i had compressed, shrink
and
> repack.
>
> Out of 106 tables those i tried to uncompress the following command fails
for
> 2 tables with the error in message log:
>
> EXECUTE FUNCTION task("table uncompress", "rvleist", "test", "informix");
> (expression) FAILED: table uncompress test:informix.rvleist
>
> 09:33:15 SCHAPI Uncompress for test:informix.rvleist started
> 09:33:15 Uncompress operation failed for test:informix.rvleist, iserrno 0
> 09:33:15 SCHAPI ERROR: table uncompress test:informix.rvleist failed
>
> I had also tried doing it offline but with no success:
>
> EXECUTE FUNCTION admin("table uncompress_offline", "rvleist", "test",> "informix");
>
> expression
> -474
>
> I dont understand what -474 is trying to tell me :(
Its a return code of admin() function.
SELECT * FROM sysadmin:command_history WHERE cmd_number = 474;
More details here -
http://publib.boulder.ibm.com/infocenter/idshelp/v115/topic/com.ibm.adref.doc/id
s_sapi_004.htm
>
> onstat -pt test:rvleist>
> TBLspace Flags 8000802 Row Locking
>
> TBLspace use 4 bit bit-maps
>
> TBLspace is compressed
>
> No changes had been made to the schema of the table after compression.
>
> What could be the possible reasons for failing to uncompress the 2
tables?
If table rvleist is fragmented and not all fragments are compressed, then
uncompress each of the compressed fragment with fragment command.
>
> Should i try uncompressing it by partnum?
>
> Any Help is appreciated!
>
> Regards
> Vikas
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
Hello Art,
I had gone crazy finding out what the issue was and the solution made me more
crazy ;)
Free space was not a constraint, I even created these 2 tables with data in
other database in same dbspace. Executed the compression,shring,repack task
and then executed the Uncompress task which to my surprise was sucessfully.
Following are the few things i tried, one out of which worked and uncompress
task for the remaining 2 tables was sucessfull, then reversion to 11.10 also
went fine.
I started with a level 0 backup and tried uncompress on this 2 tables, this
did not worked.
I checked "oncheck -pt" still showing the tables space as compressed.
To double check, executed "onmode -b 11.10" but it failed complaining about
these 2 tables again.
I then updated the whole table ( col1 = col1 where 1 = 1 ) and ran update
statistics high but it did not worked (just after the upgrade i had run update
statistics for every table and AUS is ON).
I executed the compress,shrink and repack task again for one of the table and
then executed the uncompress task which was sucessfull.
11:33:36 SCHAPI table compress test:informix.rvleist succeeded
11:34:30 SCHAPI Uncompress for test:informix.rvleist started
11:34:30 Uncompressed 0 rows in test:informix.rvleist
O rows?
"oncheck -pt" now showed compression for this table so did the same thing with
another table and it worked.
I went ahead with revertion and after droping the syscdcv1 db (forgot to drop
this earlier) the reversion was sucessfull.
I don't know what exactly the problem was (if there was any) and what trial
worked as solution.
I will be going with another round of testing to see if the same issue
troubles me again.
Regards
Vikas
*******************************************************************************
is it possible that there is not enough free space in the dbspace for the
uncompressed copy of the table?
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Tue, Aug 4, 2009 at 3:41 AM, VIKAS HIVARKAR <vikas.hivarkar@gmail.com>wrote:
> Hi all,
>
> IDS 11.50.FC4 on Solaris 10.
>
> For reverting back my test instance from 11.50.FC4 to 11.10 using "onmode
> -b
> 11.10" i have to uncompress all the tables those i had compressed, shrink
> and
> repack.
>
> Out of 106 tables those i tried to uncompress the following command fails
> for
> 2 tables with the error in message log:
>
> EXECUTE FUNCTION task("table uncompress", "rvleist", "test", "informix");> (expression) FAILED: table uncompress test:informix.rvleist
>
> 09:33:15 SCHAPI Uncompress for test:informix.rvleist started
> 09:33:15 Uncompress operation failed for test:informix.rvleist, iserrno 0
> 09:33:15 SCHAPI ERROR: table uncompress test:informix.rvleist failed
>
> I had also tried doing it offline but with no success:
>
> EXECUTE FUNCTION admin("table uncompress_offline", "rvleist", "test",> "informix");
>
> expression
> -474
>
> I dont understand what -474 is trying to tell me :(
>
> onstat -pt test:rvleist>
> TBLspace Flags 8000802 Row Locking
>
> TBLspace use 4 bit bit-maps
>
> TBLspace is compressed
>
> No changes had been made to the schema of the table after compression.
>
> What could be the possible reasons for failing to uncompress the 2 tables?
>
> Should i try uncompressing it by partnum?
>
> Any Help is appreciated!
>
> Regards
> Vikas
Related threads
- Find Index & its dbspaces
- A question about "TBLSPACE TBLSPACE"
- Help : Assertion Failure Type: CRASH
- Extents Monitoring
- Posting from the Informix-list