Re: Logging error: Assert failed !!!
Posted in 1996
Matteo Prinetti wrote: > > I'm plagued with following problem: > > (DEC OSF 3.2A , Informix 7.1.2UC1 Online Dynamic Server) > > I have 200.000 locks defined. When i try a transcation that > takes all the locks (example: delete from x - x contains > more than 200.000 records) the db shut down and cannot > recover anymore (olnly using the tbzero utility i can > restore the db). > Matteo Prinetti Can you lock the table?: LOCK TABLE tbl_name IN EXCLUSIVE MODE although when I have run out of system locks, the program crashed more gracefully than you've described and did not bring down the system. -- Sincerly, Doug Wilson(dougw@amgen.com) *** The opinions expressed here are my own and not neccessarily *** *** anyone elses **** *** Disclaimer: These are the opinions of the poster not Amgen Inc.***