Re: Hello:
Posted in 1997
Eric_Melillo@agsea.com wrote:
>
> Well...
>
> The only way to change the size of logical logs is to re-initialize the
> instance... as in: unload all data, reinitialize the engine, recreate
> the database(s), load data.
This is just wrong. You CAN change the size of the logical log files
using onparams but not from onmonitor. Reread that manual, section
23-4 in the Online 7.1 -> 7.22 Administrator's Guides. The required
steps are:
1) Bring engine to quiescent mode
2) Add new log files with new size
3) Archive level 0 to enable new logs
4) Onmode -l; onmode -c until the current checkpoint record is in one of
the logs that will not be dropped
5) Back up logs if any of the logs to be dropped have not been backed up
6) Drop any logs not wanted
7) Go online
You must be careful not to drop logs before you have added and enabled
the new logs unless there will be at least 3 old logs left after the
logs have been dropped. The engine will not initialize with less than
3 logs.
The most likely problem, assuming no bug, is that the LOGSMAX is not
great enough to permit the new logs. It looks like you had LOGSMAX
set to the same value as LOGFILES so when you dropped three logs and
then added three back you were maxed out again. Just a guess.
> cfran@opn.dem.state.in.us on 09/09/97 07:26:00 AM
> I am encountering an error when attempting to add logical logs.
> In this particular situation, I needed to add some logs while
> changing the size of others. I began by dropping 3 logical
> logs (to change the size), and then added 3 logs. When I at-
> tempted to add another log (to increase the size from 1 MB to 4
> MB, I encountered the following error:
> Cannot add a logical log. ISAM error: bad log record
> What do I need to examine when running onlog (if that is the
> first task), and what other items should I investigate to find
> a solution? I used onparams to add/drop logical logs. Our
> current version of OnLine is 7.10.UC2 on AIX 3.2. 5. Thank
> you for your assistance.
Art S. Kagel