Re: Security - seccfg
Posted in 2008
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration
On Tue, Aug 19, 2008 at 10:37 AM, Cesar Inacio Martins
<cesar_inacio_martins@yahoo.com.br> wrote:
> Hi,
> Server
> IDS 11.50 UC1 Developer
> SuSE 10.2
> Client with problem
> Windows XP
> ILOGIN - CSDK 3.50 TC1DE
>
>
> I have here a development environment , for tests motivations the role
> separation are active.
> IDS have this configuration on the seccfg file:
> > cat seccfg
> IXUSERS=ix_user
>
> Locally (linux), the users can access the database without problems with
> pyhton / dbaccess / esqlc
>
> For example, this user:
> > id bozo
> uid=1014(bozo) gid=1006(ix_user)
> groups=1006(ix_user),16(dialout),33(video)
>
> But, when I try access from windows machine with ILOGIN, the error -25571
> occur.
> On the IDS log appear:
> 14:27:51 listener-thread: err = -25571: oserr = 0: errstr = bozo: Cannot> create a user thread.
>
> I know this error on the IDS log will appear when the user not belong on the
> group configured in IXUSERS.
> But, locally users can connect and if change the seccfg to IXUSERS=* , works
> fine on the ILOGIN.
>
> So, where is my mistake ??
> I already look for more information on all documentations and not found
> anything about any kind of restriction.
>
> Can be a BUG?
If the same user name can connect locally but cannot connect remotely,
then it sounds very like a bug. I've not verified that, but I am
suspicious that it is a nasty little creepy-crawly.
--
Jonathan Leffler #include <disclaimer.h>
Email: jleffler@earthlink.net, jleffler@us.ibm.com
Guardian of DBD::Informix v2008.0513 -- http://dbi.perl.org/
"Blessed are we who can laugh at ourselves, for we shall never cease
to be amused."
NB: Please do not use this email for correspondence.
I don't necessarily read it every week, even.
On Aug 20, 5:42 am, "Jonathan Leffler" <jleffler.i...@gmail.com>
wrote:
> On Tue, Aug 19, 2008 at 10:37 AM, Cesar Inacio Martins
>
>
>
>
>
> <cesar_inacio_mart...@yahoo.com.br> wrote:
> > Hi,
> > Server
> > IDS 11.50 UC1 Developer
> > SuSE 10.2
> > Client with problem
> > Windows XP
> > ILOGIN - CSDK 3.50 TC1DE
>
> > I have here a development environment , for tests motivations the role
> > separation are active.
> > IDS have this configuration on the seccfg file:
> > > cat seccfg
> > IXUSERS=ix_user
>
> > Locally (linux), the users can access the database without problems with
> > pyhton / dbaccess / esqlc
>
> > For example, this user:
> > > id bozo
> > uid=1014(bozo) gid=1006(ix_user)
> > groups=1006(ix_user),16(dialout),33(video)
>
> > But, when I try access from windows machine with ILOGIN, the error -25571
> > occur.
> > On the IDS log appear:
> > 14:27:51 listener-thread: err = -25571: oserr = 0: errstr = bozo: Cannot> > create a user thread.
>
> > I know this error on the IDS log will appear when the user not belong on the
> > group configured in IXUSERS.
> > But, locally users can connect and if change the seccfg to IXUSERS=* , works
> > fine on the ILOGIN.
>
> > So, where is my mistake ??
> > I already look for more information on all documentations and not found
> > anything about any kind of restriction.
>
> > Can be a BUG?
>
There is a possibility that it is a bug. The product you are using are
developer edition products. I believe these are supported through the
IBM developerWorks forum.
I think this is the URL
http://www.ibm.com/developerworks/forums/forum.jspa?forumID=548
And t
Related threads
- Transaction not available
- Error -25571 errstr = informix : Cannot creta a us
- Bug? Role Separation ... informix can't access...
- NETTYPE maximum support to user connections ?