Problem Building the sysmaster database
Posted in 2005
Topics: Error Codes & Troubleshooting, Networking & sqlhosts Configuration
Ok my friends, thanks for
answer me the last post, i resolved the error
matching the INFORMIXSERVER with sqlhosts file in INFORMIXDIR/etc and
using Setnet too.
Well, now when i am trying to use the oninit command for build the system
database, i'll get this error message:
this is in my <servername>.log
+-----------------------------------------------------------+
01:09:49 Assert Failed: build_smi failed
01:09:49 Informix Dynamic Server Version 7.31.TD5
01:09:49 Who: Session(10, informix@pc01, 0, 0)
Thread(29, build_smi, 0, 1)
File: \\\\tristarm\\\\rsam\\\\rspseudo.c Line: 7599
01:09:50 Results: Cannot build/check 'sysmaster' database
+-----------------------------------------------------------+
And this is in my buildsmi_out.<servername>, that is the ouput
of buildsmi.bat
+-----------------------------------------------------------+
908: Attempt to connect to database server (ol_pc01) failed.
Connection refused
Error in line 23Near character position 1
Cleaning up whatever was successfully created
908: Attempt to connect to database server (ol_pc01) failed.
Connection refused
201: A syntax error has occurred.
+----------------------------------------------------------+
I'm very very closer to getting up my server, please if anyone
can help me with this last step, i'll be so gracefull for
helping me to learn more about this great Database.
Jose,
first thing to do is to check your INFORMIXSERVER env
variable for the informix user.
this one "ol_pc01" doesn't seem to work.
check your sqlhosts file and whether the oninit is up
and running.
Basically your problem seems to be:
1) the oninit is not up and running
or
2) you are using the wrong informixserver values
esteban.-
--- JOSE DLEON <darkbitez@yahoo.com> escribis:
> Ok my friends, thanks for answer me the last post, i
> resolved the error
> matching the INFORMIXSERVER with sqlhosts file in
> INFORMIXDIR/etc and
> using Setnet too.
> Well, now when i am trying to use the oninit command
> for build the system
> database, i'll get this error message:
>
>
> this is in my <servername>.log
>
+-----------------------------------------------------------+
> 01:09:49 Assert Failed: build_smi failed
> 01:09:49 Informix Dynamic Server Version 7.31.TD5
>
> 01:09:49 Who: Session(10, informix@pc01, 0, 0)
> Thread(29, build_smi, 0, 1)
> File: \\\\tristarm\\\\rsam\\\\rspseudo.c Line: 7599
> 01:09:50 Results: Cannot build/check 'sysmaster'
> database
>
+-----------------------------------------------------------+
>
> And this is in my buildsmi_out.<servername>, that is
> the ouput
> of buildsmi.bat
>
+-----------------------------------------------------------+
>
> 908: Attempt to connect to database server
> (ol_pc01) failed.>
> Connection refused
> Error in line 23> Near character position 1
> Cleaning up whatever was successfully created
>
> 908: Attempt to connect to database server
> (ol_pc01) failed.>
> Connection refused
>
> 201: A syntax error has occurred.>
>
>
+----------------------------------------------------------+
>
> I'm very very closer to getting up my server, please
> if anyone
> can help me with this last step, i'll be so
> gracefull for
> helping me to learn more about this great Database.
>
>
___________________________________________________________
1GB gratis, Antivirus y Antispam
Correo Yahoo!, el mejor correo web del mundo
http://correo.yahoo.com.ar