In article <35C0C097.2879@bloomberg.net>, Art S. Kagel
<kagel@bloomberg.net> writes
>There's the problem! ISAM error -144 indicate not that the record is
>locked but that the index key is locked. This can happen when a key
>value is updated both the original key node and the new key node in the
>index must be locked, in each affected index, until the transaction is
>committed. The engine does this not the application. You must SET
Correct, hence you really want each index key to be unique!!
i.e. have a serial )or integer) unique key on the table (to keep
the increase in key size small) and add it to the end of the list
of columns in the index.
All indexes should be UNIQUE!!!
>LOCK MODE TO WAIT 5; (or some other brief value reasonable in your
>environment). In this way each user's brief lock will not cause
>someone else's transaction to fail.
>
>> 3. Is this a documented bug ?
>
>Actually not a bug at all, but definitely documented behavior.
>
>Art S. Kagel
--
David Williams
Maintainer of the Informix FAQ
Primary site (Beta Version) http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html
I see you standin', Standin' on your own, It's such a lonely place for you, For
you to be If you need a shoulder, Or if you need a friend, I'll be here
standing, Until the bitter end...
So don't chastise me Or think I, I mean you harm...
All I ever wanted Was for you To know that I care