DBACCES error -952, SCO unix
Posted in 2004
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Server Administration, Security, Permissions & Auditing, Platform-Specific Issues, Internationalization & Character Sets, Versions, Editions & End-of-Life
Un saludo a todos: SCO UNIX 5.0.4 IDS 7.30 UC2 ISQL, I4GL 6.01.UD1 INFORMIX CLIENT 2.01 Todas las estaciones locales y via telnet trabajan sin problemas con el isql y el i4gl. Al tratar de conectarme con el DBACCESS /Connection/Connect y dar el nombre de usuario y password correcto da el error -952, lo mismo pasa con el user informix y su pasword. Ya sea local o via telnet. Pero, tambien con el Dbaccess, si en lugar de colocar el nombre de usuario, coloco enter, si logro conectarme a la base de datos. Lei bastante de que en linux se coluciona cambiando de shadows passwords a unsahdows password. Asi se soluciona con SCo UNIX ??? Es otra la falla?? Si se soluciona de esta manera, como debo de hacerlo??? Cualquier idea sera binevenida Gracias Luis Camacho.
Hola,
( por favor escribe en Ingles ... )
Since my Spanish is less than basic I write in English ...
>Pero, tambien con el Dbaccess, si en lugar de colocar el nombre de
usuario,
>coloco enter, si logro conectarme a la base de datos.
I do not really understand this sentence. Are you saying that
it depends on the location of dbaccess ? Or does it depend
on the location of the server to which you're connecting ?
The location of dbaccess should not matter. The authentication
is done by the server.
Possible causes:
- Have you configured a password encryption algorithm different
than normal ( e.g. MD5 instead of standard UNIX crypt() ) ?
- Have you configured something to get passwords from the
network (e.g. NIS/NIS+ or PAM) ?
- Are you sure the file access rights of "oninit" in the server
installation are correct ? (Check "ls -l $INFORMIXDIR/bin/oninit".
it should be "-rwsr-sr.. root informix ... oninit".)
This is what I can think of right now.
Saludos,
Martin
--
Martin Fuerderer
IBM Informix Development Munich
Data Management Solutions
"laboratorio" <laboratorio@eldiario.net>
Sent by: forum.subscriber@iiug.org
20.01.2004 00:45
To: ids@iiug.org
cc:
Subject: DBACCES error -952, SCO unix [2449]
Un saludo a todos:
SCO UNIX 5.0.4
IDS 7.30 UC2
ISQL, I4GL 6.01.UD1
INFORMIX CLIENT 2.01
Todas las estaciones locales y via telnet trabajan sin problemas con el
isql
y el i4gl.
Al tratar de conectarme con el DBACCESS /Connection/Connect y dar el
nombre
de usuario y password correcto da el error -952, lo mismo pasa con el user
informix y su pasword.
Ya sea local o via telnet.
Pero, tambien con el Dbaccess, si en lugar de colocar el nombre de
usuario,
coloco enter, si logro conectarme a la base de datos.
Lei bastante de que en linux se coluciona cambiando de shadows passwords a
unsahdows password.
Asi se soluciona con SCo UNIX ???
Es otra la falla??
Si se soluciona de esta manera, como debo de hacerlo???
Cualquier idea sera binevenida
Gracias
Luis Camacho.