ODBC connections iffy after new kernel
Posted in 2007
Topics: Connectivity: ODBC / JDBC / .NET, Platform-Specific Issues
Greetings all- I'm trying to troubleshoot ODBC connections that 40% of the time connect and 60% of the time get an error -27001. On our HP-UX 11i ver1 box I just recompiled the kernel to add in the KAIO driver (asyncdsk) and subsequently had to reboot. (I did not setup informix to use KAIO yet, there are a couple of configurations to perform, which I planned on doing after making sure the new kernel booted.) I'm not sure if the cause is the new kernel or something brought on by the reboot. How do I go about troubleshooting ODBC connections? I'm connecting from WinXP clients using iConnect 2.90. I set things up in setnet then use iLogin to test. I have tried turning on the 'trace' functionality in the Windows ODBC admin tool too, but it has not written anything to the log file it created. Its supposed to capture all communications between client and server. Most of our clients connect via ssh and use a shm/ipc connection just fine. Its our report writing software (Cognos Impromptu) that uses ODBC from windows clients that isnt working. I'm thinking of reverting back to the old kernel, but if that doesnt fix it I'd like to know how to troubleshoot this problem. If anyone has any suggestions they'd be greatly appreciated.
Hi, Maybe any of these ideas help: - At the O/S level (HP-UX) of the Informix server machine: Check for kernel parameter settings related to network/communications (specially TPC/IP parameters) and sockets (such as NOFILES --number of open file descriptors), and check for upgrades or patches required for communication issues. - At the Informix server: Tune the NETTYPE settings for TCP communication at the ONCONFIG file. - At the Informix client machine: Check all the environment variables for the TCP/IP connection to the Informix server. - Whenever you have a chance: - bring instance down - clean up all the content under /INFORMIXTMP (only files for this particular instance / tcp service) - restart the instance - test the connections This article explains some common causes and solutions for the network error -27001: Error 27001, Unable to connect via tcp network connections http://www-1.ibm.com/support/docview.wss?uid=swg21165598 Hope this helps, Regards, Veronica. > To: ids@iiug.org > From: cnelson@fwps.org > Subject: ODBC connections iffy after new kernel [10316] > Date: Mon, 5 Nov 2007 18:15:21 -0500 > > Greetings all- > > I'm trying to troubleshoot ODBC connections that 40% of the time connect and > 60% of the time get an error -27001. On our HP-UX 11i ver1 box I just > recompiled the kernel to add in the KAIO driver (asyncdsk) and subsequently > had to reboot. (I did not setup informix to use KAIO yet, there are a couple > of configurations to perform, which I planned on doing after making sure the > new kernel booted.) > > I'm not sure if the cause is the new kernel or something brought on by the > reboot. How do I go about troubleshooting ODBC connections? I'm connecting > from WinXP clients using iConnect 2.90. I set things up in setnet then use > iLogin to test. I have tried turning on the 'trace' functionality in the > Windows ODBC admin tool too, but it has not written anything to the log file > it created. Its supposed to capture all communications between client and > server. > > Most of our clients connect via ssh and use a shm/ipc connection just fine. > Its our report writing software (Cognos Impromptu) that uses ODBC from windows > clients that isnt working. > > I'm thinking of reverting back to the old kernel, but if that doesnt fix it > I'd like to know how to troubleshoot this problem. > > If anyone has any suggestions they'd be greatly appreciated. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > _________________________________________________________________ Express yourself instantly with MSN Messenger! Download today it's FREE! http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/