Re: Strange Lockups on IDS 7.31.UD8
Posted in 2005
Hi,
the onconfig file parameters look fine.
Check the AF-file (/db0/tmp/af.482edd9) as adviced
in the online.log. If that doesn't clarify things, you should
probably open a "Case" with IBM Informix Tech Support
to have them help analyze the cause of this. They may
also request the SHM dump (file shmem.482edd9.0) for
analysis.
I'm not sure whether the message about the "bad I/O request" is
directly connected to the preceeding messages, but it may well
be. Tech Support will be able to tell by the chunk and page
number ...
I've seen systems that had such "transient I/O errors" not because
of the I/O subsystem, but because of processor cache latency
that showed different content of the same page to different CPUs.
And that is just one possibility ...
The listener-thread message most probably has a different cause.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
owner-informix-list@iiug.org wrote on 16.08.2005 23:37:23:
> The machine is the same one that we've been using for about ... 2
> years. We've been running IDS on it the whole time.
>
> However, that doesn't mean those values haven't been wrong the whole
> time. The values for the parameters you asked about are:
>
> MULTIPROCESSOR 1 # 0 for single-processor, 1 for> multi-processor
> NUMCPUVPS 2 # Number of user (cpu) vps
> SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps> to one
>
> I also noticed the index errors from last Thursday look more like:
>
> 09:44:58 Assert Failed: ptmap
> 09:44:58 IBM Informix Dynamic Server Version 7.31.UD8
> 09:44:58 Who: Session(19, informix@corp.inventconnect.com, -1,> 2146684976)
> Thread(154, sqlexec, 7ff2b3c0, 1)
> File: rspartn.c Line: 1867
> 09:44:58 Results: Could not complete operation on> 'development:"root".invention'
> 09:44:58 Action: Run 'oncheck -cDI development:"root".invention'
> 09:45:02 See Also: /db0/tmp/af.482edd9, shmem.482edd9.0
> 09:46:35 I/O bad request chunk 4095, pagenum 1048575, pagecnt 1
> 09:46:39 listener-thread: err = -25587: oserr = 0: errstr = : Network> receive failed.
>
> However, running an oncheck -cDI doesn't show any problems (other than
> the bad index). I would expect to see something about a bad chunk.
> Isn't that what the above error states?
>
> --Anthony
sending to informix-list