Re: -952 Authentication Error on Solaris 10
Posted in 2009
Topics: Backup & Restore, Connectivity: ODBC / JDBC / .NET, Server Administration, Security, Permissions & Auditing, Platform-Specific Issues, Versions, Editions & End-of-Life
On Mar 26, 4:41 pm, nate...@kc.rr.com wrote:
> I'm running IDS 9.40.FC9 on two new Solaris 10 DB servers - one for
> prod, one for test. The prod one is live and functioning OK. I'm in
> the process of setting up the test one (a little backwards, I know,
> but there are reasons...). I can log into the test box through SSH
> with informix and a couple of different accounts used by the
> application. I can open dbaccess and run SQL commands just fine.
> However, when I attempt to connect from a Windows server via ODBC or
> ILoginDemo, I get a -952 error that the password validation failed.
> Here is the message that appears in the online log:
> Password validation for user [nate] failed!
> Check for password aging/account lock-out.
> listener-thread: err = -952: oserr = 0: errstr = nate: User (nate)'s
> password is not correct for the database server.
> I'm at a loss as to how I can SSH into the server, but still get an
> authentication error when I try to connect to Informix with the same
> account information. Any thoughts or ideas would be greatly
> appreciated.
> Thanks,
> Nate
I never did figure out what the root cause of the problem was. We
ended up restoring an OS backup from prod to test, and after restoring
a Level 0 backup to the test DB server everything started working.
Thanks for all the suggestions.
-Nate
On Mar 31, 6:04 pm, nate...@kc.rr.com wrote:
> On Mar 26, 4:41 pm, nate...@kc.rr.com wrote:
>
>
>
> > I'm running IDS 9.40.FC9 on two new Solaris 10 DB servers - one for
> > prod, one for test. The prod one is live and functioning OK. I'm in
> > the process of setting up the test one (a little backwards, I know,
> > but there are reasons...). I can log into the test box through SSH
> > with informix and a couple of different accounts used by the
> > application. I can open dbaccess and run SQL commands just fine.
> > However, when I attempt to connect from a Windows server via ODBC or
> > ILoginDemo, I get a -952 error that the password validation failed.
> > Here is the message that appears in the online log:
> > Password validation for user [nate] failed!
> > Check for password aging/account lock-out.
> > listener-thread: err = -952: oserr = 0: errstr = nate: User (nate)'s
> > password is not correct for the database server.
> > I'm at a loss as to how I can SSH into the server, but still get an
> > authentication error when I try to connect to Informix with the same
> > account information. Any thoughts or ideas would be greatly
> > appreciated.
> > Thanks,
> > Nate
>
> I never did figure out what the root cause of the problem was. We
> ended up restoring an OS backup from prod to test, and after restoring
> a Level 0 backup to the test DB server everything started working.
> Thanks for all the suggestions.
> -Nate
Ok. That's one way to take care of it. ;-)
We had 2 users that could not connect to the database. Both of these users connect from Windoze via ODBC. I could ssh using these accounts with no problems. What we found was that JASS had changed the encryption in /etc/security/policy.conf and this line needed to be uncommented
CRYPT_ALGORITHMS_DEPRECATE=__unix__
we recreated the users (& passwords) before commenting it out again.
HTH
Regards
Colin
There are 10 types of people in the world, those that understand binary and those that don't
> From: im_gumby@hotmail.com
> Subject: Re: -952 Authentication Error on Solaris 10
> Date: Wed, 1 Apr 2009 08:57:35 -0700
> To: informix-list@iiug.org
>
> On Mar 31, 6:04 pm, nate...@kc.rr.com wrote:
> > On Mar 26, 4:41 pm, nate...@kc.rr.com wrote:
> >
> >
> >
> > > I'm running IDS 9.40.FC9 on two new Solaris 10 DB servers - one for
> > > prod, one for test. The prod one is live and functioning OK. I'm in
> > > the process of setting up the test one (a little backwards, I know,
> > > but there are reasons...). I can log into the test box through SSH
> > > with informix and a couple of different accounts used by the
> > > application. I can open dbaccess and run SQL commands just fine.
> > > However, when I attempt to connect from a Windows server via ODBC or
> > > ILoginDemo, I get a -952 error that the password validation failed.
> > > Here is the message that appears in the online log:
> > > Password validation for user [nate] failed!
> > > Check for password aging/account lock-out.
> > > listener-thread: err = -952: oserr = 0: errstr = nate: User (nate)'s
> > > password is not correct for the database server.
> > > I'm at a loss as to how I can SSH into the server, but still get an
> > > authentication error when I try to connect to Informix with the same
> > > account information. Any thoughts or ideas would be greatly
> > > appreciated.
> > > Thanks,
> > > Nate
> >
> > I never did figure out what the root cause of the problem was. We
> > ended up restoring an OS backup from prod to test, and after restoring
> > a Level 0 backup to the test DB server everything started working.
> > Thanks for all the suggestions.
> > -Nate
>
> Ok. That's one way to take care of it. ;-)
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
_________________________________________________________________
Share your photos with Windows Live Photos – Free.
http://clk.atdmt.com/UKM/go/134665338/direct/01/