RE: IBM Informix Dynamic Server Version 12.10.UC4W1
Posted in 2020
Hello SangGyu, many thanks for your response. I also believe that it is the defect you indicated. Your information will help me decide what to do. Have a nice day. Greetings Heinz WESTFLEISCH SCE mit beschränkter Haftung, Hauptsitz: Brockhoffstr. 11, 48143 Münster Amtsgericht Münster: Gen.-Reg. 448 Aufsichtsratsvorsitzender: Josef Lehmenkühler Vorstand: Dirk Niederstucke (Vorsitzender); Peter Piekenbrock; Gerhard Meierzuherde; Carsten Schruck, Johannes Steinhoff, Steen Sönnichsen (Geschäftsführer) ------Original Message------ Hello Heinz, This problem is probably a defect of informix. It looks similar to what is described in the APAR below. Commonly, Informix 12.10.xC4 and below are in use and last commited function is enabled. In this state, AF occurs when an alter operation is performed on a compressed or uncompressed table. IT04586: ASSERT FAILED: PHYSICAL_SCAN: DECOMPRESS_ROW, SOURCE = 0XXXXXXXX X, TARGET = 0XXXXXXXXX WHEN USELASTCOMMITTED "ALL" , COMPRESSION https://www-01.ibm.com/support/docview.wss?uid=swg1IT04586 IT03514: ASSERT FAILED ROWALTER: PTOCOPYVC: COLLEN (X) > MAX_VC_LEN (Y) FOLLOWED BY ASSERT FAILED PHYSICAL_SCAN: DECOMPRESS_ROW https://www-01.ibm.com/support/docview.wss?uid=swg1IT03514 If possible, I would recommend Informix to apply patch 12.10.xC5 or higher. In this case, of course, it is recommended to ask IBM to open the case. If that's hard to do, you might need to migrate your data to a new table. ------------------------------ SangGyu Jeong Software Engineer Infrasoft Seoul Korea, Republic of ------------------------------ #Informix