Re: Informix 7.2Se and ADO from Vb
Posted in 1999
Topics: Connectivity: ODBC / JDBC / .NET, Server Administration, Transactions, Locking & Isolation
Hi, The database supports transactions and the provider is "MSDASQL.1". The chap I am looking into this for is converting a vb3 application to vb6 and in the process he is attempting to convert the database.begintrans... to their ado equivalents connection.begintrans this results in a error stating that:- -2147168248 Neither the isolation level or a stregthening of it can be supported. I will be testing the transactions by executing native begintrans committrans pairs. cheers MIchael Oussama MKaabal <oussama@isg.co.il> wrote in message news:7gmkc8$emu$1@news.netvision.net.il... > Hi , > > in order to give you an answer i need to know more ... > 1) who is youre ADO(OLE-DB) provider ... or are you working throught Kagira > through ODBC ... > > things to check ... > 1) can you sork or start transactions not through ADO... maybe your database is > not set to to work with transactions ... > if not refere to your administration guid on setting the database in > transaction Mode ... > > 2) else check if your provider supports transactions ... > > Michael Muir-Browe <Michael@nospam.truecs.force9.co.uk> wrote in message > news:%RyX2.1179$%x.986@wards... > Hi Anyone out there using ADO with Infromix Se ? We are having problem with > begintrans failing > > cheers > > Michael > > > >
Sorry forgot to mention the ODBC driver is the Intersolv v3.11 Informix 9 driver. Thanks Michael Muir-Browe <Michael@nospam.truecs.force9.co.uk> wrote in message news:5mDX2.1195$%x.1037@wards... > Hi, > > The database supports transactions and the provider is "MSDASQL.1". > > The chap I am looking into this for is converting a vb3 application to vb6 > and in the process he is attempting to convert the database.begintrans... to > their ado equivalents > > connection.begintrans this results in a error stating that:- > > -2147168248 Neither the isolation level or a stregthening of it can be > supported. > > I will be testing the transactions by executing native begintrans > committrans pairs. > > > cheers > > MIchael > > > Oussama MKaabal <oussama@isg.co.il> wrote in message > news:7gmkc8$emu$1@news.netvision.net.il... > > Hi , > > > > in order to give you an answer i need to know more ... > > 1) who is youre ADO(OLE-DB) provider ... or are you working throught > Kagira > > through ODBC ... > > > > things to check ... > > 1) can you sork or start transactions not through ADO... maybe your > database is > > not set to to work with transactions ... > > if not refere to your administration guid on setting the database > in > > transaction Mode ... > > > > 2) else check if your provider supports transactions ... > > > > Michael Muir-Browe <Michael@nospam.truecs.force9.co.uk> wrote in message > > news:%RyX2.1179$%x.986@wards... > > Hi Anyone out there using ADO with Infromix Se ? We are having problem > with > > begintrans failing > > > > cheers > > > > Michael > > > > > > > > > >