Re: SCO locking problem
Posted in 1999
David
Dont think anything is wrong with the kernel. Your problem appears to be a
locking problem caused by the application program you are running. If you
do a finderr -263 and a finderr -107, it will tell you in detail what is
wrong. In addition to using SET LOCK MODE TO WAIT, you could also check to
see if the tables in your database have page-level locking (SELECT tabname,
locklevel FROM systables WHERE tabid > 99) and if they are, you can change
them to use row-level locking (ALTER TABLE tablename LOCK MODE (ROW)).
HTH
Sujit
David Mendes <dmendes@fasoft.pt> on 06/03/99 03:28:43 AM
Please respond to David Mendes <dmendes@fasoft.pt>
To: informix-list@iiug.org
cc: (bcc: Sujit Pal)
Subject: SCO locking problem
Hi all,
I had a system running SCO 3.4.2 with I-SE v.4.1. The system was running
for years with some 4GL programs. The system has a load of 2 or 3 users
on the program.
We've updated the SE for 7.1.
Now, when there is only one user everything works fine but when there
are 2 or more it sometimes hans with the following error:
SQL statement error number -263.
Could not lock row for UPDATE.
System error number -107.
ISAM error: record is locked.
It appears to be some kind of misconfiguration in the kernel (?), we
have the row locking variable in the kernel set to a high value
(FLCKREC=800) but it still has the problem ?
What is happening ?
Please help me !
David Mendes