save sql trace in message log
Posted in 2010
Topics: Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
hello all
we see this in the message log and are not sure exactly why and what
is the process to correct it.
---
07:15:00 SCHAPI: [Save SQL Trace 21-1597] Error -310 Table
(informix.mon_syssqltrace_info) already exists in database.
we are assuming it is not a huge problem but on the other hand, not
one to be ignored.
Version 11.50.FC6 on AIX 6.1
any insight is appreciated - Thank you
Tom
++++
07:00:00 SCHAPI: [Save SQL Trace 21-1596] Error -310 Table
(informix.mon_syssqltrace_info) already exists in database.
07:02:14 Checkpoint Completed: duration was 0 seconds.
07:02:14 Mon Mar 22 - loguniq 113, logpos 0xbe2d018, timestamp:0x407c6741 Interval: 12306
07:02:14 Maximum server connections 155
07:02:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txnsblocked 0, Plog used 58, Llog used 195
07:12:14 Checkpoint Completed: duration was 0 seconds.
07:12:14 Mon Mar 22 - loguniq 113, logpos 0xbee6018, timestamp:0x407c8525 Interval: 12307
07:12:14 Maximum server connections 155
07:12:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txnsblocked 0, Plog used 32, Llog used 185
07:15:00 SCHAPI: [Save SQL Trace 21-1597] Error -310 Table
(informix.mon_syssqltrace_info) already exists in database.
07:22:14 Checkpoint Completed: duration was 0 seconds.
07:22:14 Mon Mar 22 - loguniq 113, logpos 0xbfc8018, timestamp:0x407ca763 Interval: 12308
07:22:14 Maximum server connections 155
07:22:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txnsblocked 0, Plog used 180, Llog used 226
On 22 Mar, 12:34, Tom Lehr <tomc...@gmail.com> wrote:
> hello all
> we see this in the message log and are not sure exactly why and what
> is the process to correct it.
> ---
> 07:15:00 SCHAPI: [Save SQL Trace 21-1597] Error -310 Table
> (informix.mon_syssqltrace_info) already exists in database.>
> we are assuming it is not a huge problem but on the other hand, not
> one to be ignored.
> Version 11.50.FC6 on AIX 6.1
> any insight is appreciated - Thank you
> Tom
>
> ++++
> 07:00:00 SCHAPI: [Save SQL Trace 21-1596] Error -310 Table
> (informix.mon_syssqltrace_info) already exists in database.
> 07:02:14 Checkpoint Completed: duration was 0 seconds.
> 07:02:14 Mon Mar 22 - loguniq 113, logpos 0xbe2d018, timestamp:> 0x407c6741 Interval: 12306
> 07:02:14 Maximum server connections 155
> 07:02:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns> blocked 0, Plog used 58, Llog used 195
> 07:12:14 Checkpoint Completed: duration was 0 seconds.
> 07:12:14 Mon Mar 22 - loguniq 113, logpos 0xbee6018, timestamp:> 0x407c8525 Interval: 12307
> 07:12:14 Maximum server connections 155
> 07:12:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns> blocked 0, Plog used 32, Llog used 185
> 07:15:00 SCHAPI: [Save SQL Trace 21-1597] Error -310 Table
> (informix.mon_syssqltrace_info) already exists in database.
> 07:22:14 Checkpoint Completed: duration was 0 seconds.
> 07:22:14 Mon Mar 22 - loguniq 113, logpos 0xbfc8018, timestamp:> 0x407ca763 Interval: 12308
> 07:22:14 Maximum server connections 155
> 07:22:14 Checkpoint Statistics - Avg. Txn Block Time 0.000, # Txns> blocked 0, Plog used 180, Llog used 226
As per http://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic=/com.ibm.admin.doc/ids_admin_1117.htm
Check the tasks setup for the Informix Internal Scheduer API
(SCHAPI) , basically check the ph_task table in the sysadmin database
for something that is trying to save sql trace information.
As per
http://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic=/com.ibm.dapip.doc/sii081061008.htm&resultof=%22Save%22%20%22save%22%20%22SQL%22%20%22sql%22%20%22Trace%22%20%22trace%22
the OpenAdmin Tool (OAT) has the ability to view saves SQL trace data.
Management of the SQL Tracing Feature is documented at
http://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic=/com.ibm.adref.doc/ids_sapi_078.htm&resultof=%22set%22%20%22sql%22%20%22tracing%22%20%22trace%22%20%22saved%22%20%22save%22
and the SQL Tracing feature is documented at
http://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic=/com.ibm.admin.doc/ids_admin_1126.htm
and allows viewing sql executions including
- database name
- finish time, time the associated transaction started,number of
executions, average and max duration
- SQL text (up to 1600 characters) , host variable values, procedure
stacks
- number of tables and name of tables (up to 4096 chars) used in the
statement
- buffers read/writes,disk reads/writes,read/write cache
percentages,number if index buffer reads
- number of sorts and disk sorts, sort memory used, total memory used
- log space used (a feature the DB2 requires you to pay for the Log
Miner addon),
- estimated number of rows returned (estimated by the optimizer) and
actual number of rows returned
- number of lock request/waits and lock wait time
- number of io waits,average and total io wait time (total excludes
async io)
- rows per second returned
You can enable tracing at the server,database, user or session level
( very cool, requires 11.50.xC3+) as well as change the number and
size of the trace buffers while the database server is running. If you
resize the trace buffer, the database server attempts to maintain the
content of the buffer.