Re: Help! Bad/unwanted chunks in rootdbs
Posted in 1993
andrew.shaw writes: |> I hope someone can help me with the following problem - my reading of |> TFM seems to indicate that there is no solution: |> |> Our rootdbs has the following chunks: |> |> Chunk Offset Pages Used Status |> 1 1 263873 239295 PO- |> 2 0 524287 524287 PO- |> 3 1 589439 3 PO- |> |> Chunk 3 was assigned to rootdbs in error - we would like it to be used |> for a different, droppable, dbspace. |> |> Chunk has an offset of 0 - we think this is an error because |> 1. We get read() errors from time to time, and |> 2. It seems improbably full (especially since chunk |> 1 is not). |> |> What we would like to do, therefore, is somehow back up the data, drop |> the rootdbs and its chunks, allocate the chunks to 2 different dbspaces, |> and then restore the data. |> |> It seems clear that we cannot use tbunload/tbload for the backups, but |> even if we use dbunload, how on earth do we drop the rootdbs (or at |> least deallocate the second two chunks)? What makes you think you cannot use tbunload? That is *exactly* what I would suggest: tbunloading all the databases in your system. Then just go ahead and REINITIALIZE your whole OnLine system, then readd the chunks, creating appropriate dbspaces as necessary. When you are done, tbload the databases back into the system. Pre-6.0, you cannot drop a chunk from a dbspace, you can only drop the entire (empty) dbspace. The root dbspace is a special case: it can never be dropped. Dave Disclaimer: These opinions are not those of Informix Software, Inc. ************************************************************************** "I look back with some satisfaction on what an idiot I was when I was 25, but when I do that, I'm assuming I'm no longer an idiot." - Andy Rooney