Locked out in exclusive mode
Posted in 1999
Topics: Error Codes & Troubleshooting
Hello While connected to a database in exclusive mode, my connection was lost and I crashed out. I cannot now use the database as it is 'in use by another user' (trying to connect gives errors 425: Database is currently opened by another user. and 113: ISAM error: the file is locked). How can I bring the db out of this lock and be able to connect again? I urgently need to reconnect. Any help would be much appreciated. (I'm using Informix-sql 4.20UC3, Engine SE 5.10UC1 running on SCO Unix) My e-mail adress : ckipp@itad.co.uk
onstat -u :: find your thread (process) id
onmode -z {sesid} :: Kill the process. Depending upon your loggin status, what your session was doing, transactions etc. this
might take
a while.
Good Luck,
Terry Hillick
tcom Newsgroups wrote:
> Hello
>
> While connected to a database in exclusive mode, my connection was lost and
> I crashed out. I cannot now use the database as it is 'in use by another
> user' (trying to connect gives errors 425: Database is currently opened by
> another user. and 113: ISAM error: the file is locked).
> How can I bring the db out of this lock and be able to connect again? I
> urgently need to reconnect.
>
> Any help would be much appreciated.
>
> (I'm using Informix-sql 4.20UC3, Engine SE 5.10UC1 running on SCO Unix)
>
> My e-mail adress : ckipp@itad.co.uk
The problem was indeed solved by killing the process left running after the
crash. Thanks to those who suggested it.
I did phone informix, although they only managed to suggest rebooting (not
realistically possible) and closing the db through dbaccess, which of course
you can't do as you're locked out!!