Re: Informix and JDBC
Posted in 1999
Marius Aabel wrote: > I have problems connecting to a informix SE on linux form JDBC. The > database is installed and up running. The JDBC (1.4) is installed. When > I try to run the CreateDB.class from the /demo/basics catalog, I only > get an error message: > > URL = > "jdbc:informix-sqli://xxx.xxx.xxx.xxx:1533:informixserver=leadsdb;user=test;password=test" > > ERROR: failed to connect! [SNIP] Marius, A few suggestions: 1) Try writing INFORMIXSERVER (i.e. all capital letters) 2) Your hostname -- xxx.xxx.xxx.xxx -- looks strange to me 3) After the port number -- 1533 -- and before the colon character -- ":" -- insert two slash characters -- "//" -- followed by the name of the database you want to connect to. HTH, Avi. -- /\\ \\ /| Avi Abrami, Analyst/Programmer, Telegate Ltd. /__\\ \\ / | 7 Haplada Street, Or-Yehuda, ISRAEL / \\ \\/ | Phone:+972-3-5388717 Fax:+972-3-5335877 eMail:avia@telegate.co.il