unable to load locale categories
Posted in 2004
Topics: Installation, Setup & Upgrades, Platform-Specific Issues, Internationalization & Character Sets
I have a Solaris machine running Informix 7.31. I have a Linux machine with the Informix SDK installed. I have a number of php scripts on the Linux box that have been working flawlessly, connecting to Informix and doing various queries and updates. At some point, the scripts quit working (with no apparent changes on either machine, of course). When attempting to establish a connection to Informix, I get the "unable to load locale categories" error. I've searched the archives and found a number of references to this error message, but I'm not following the thread too well. I've searched the Informix Administrator's guide for information about locale's, and it basically says it assumes I'm using the default. It also references a sysdbslocale table but doesn't say a lot about it. I have another Solaris machine with the SDK loaded that is still connecting to Informix on the other machine just fine. What should I be looking for to get this connection from the Linux box working again? Thanks, Brian McLaughlin Administrative Computing George Fox University bmclaugh@georgefox.edu (503) 554-2587
Hi, typically this is a problem of $INFORMIXDIR. Either $INFORMIXDIR is not set correctly, or the locale files in $INFORMIXDIR cannot be found/read (for whatever reason). If in doubt, you can install the product anew, i.e. to make sure that the installation is complete and all files are there ... Regards, Martin -- Martin Fuerderer IBM Informix Development Munich Data Management Solutions forum.subscriber@iiug.org wrote on 07.08.2004 00:05:33: > I have a Solaris machine running Informix 7.31. I have a Linux machine with the Informix SDK installed. I have a number of php scripts on the Linux box that have been working flawlessly, connecting to Informix and doing various queries and updates. > > At some point, the scripts quit working (with no apparent changes on either machine, of course). When attempting to establish a connection to Informix, I get the "unable to load locale categories" error. > > I've searched the archives and found a number of references to this error message, but I'm not following the thread too well. I've searched the Informix Administrator's guide for information about locale's, and it basically says it assumes I'm using > the default. It also references a sysdbslocale table but doesn't say a lot about it. > > I have another Solaris machine with the SDK loaded that is still connecting to Informix on the other machine just fine. > > What should I be looking for to get this connection from the Linux box working again? > > Thanks, > > Brian McLaughlin > Administrative Computing > George Fox University > bmclaugh@georgefox.edu > (503) 554-2587 > > >