panic
Posted in 2007
Topics: Storage & Space Management, Error Codes & Troubleshooting, Logging & Checkpoints, Versions, Editions & End-of-Life
I had a server panic Saturday night and shut down.
When IDS was manually restarted Sunday morning, it came up fine and commited 4360 rows
This is IDS 9.4.TC2 on Windows 2000.
This has never happened in the 3 years the server has been running.
Why would this happen?
Should I be concerned that a drive is going out?
This is a portion of the log:
05:01:00 Fuzzy Checkpoint Completed: duration was 0 seconds, 237 buffers not flushed,timestamp: 452326139.
05:01:00 Checkpoint loguniq 3957, logpos 0xaf8b74, timestamp: 452326154
05:01:00 Maximum server connections 187
05:11:00 KAIO: error in kaio_WRITE, kaiocbp = 0x277647c8, errno = 2
05:11:00 fildes = 484 (gfd 7), buf = 0x294EA018, nbytes = 4096, offset = 447930368
05:11:00 I/O write chunk 6, pagenum 109358, pagecnt 1 --> errno = 2
05:11:00 Logical Logging error for 'OLDRSAM:CKPOINT' in 'logput'
05:11:02 Assert Failed: Dynamic Server must abort
05:11:02 IBM Informix Dynamic Server Version 9.40.TC2
05:11:02 Who: Session(1, informix@bob.cheerco.net, 0, 00000000)
Thread(6, main_loop(), 0, 1)
File: rslog.c Line: 3406
05:11:03 Results: Dynamic Server must abort
05:11:03 Action: Reinitialize shared memory
05:11:03 stack trace for pid 704 written to H:\\temp\\af.3ee8534
05:11:04 See Also: H:\\temp\\af.3ee8534, shmem.3ee8534.0
05:13:00 PANIC: Attempting to bring system down
05:13:00 rslog.c, line 3406, thread 6, proc id 704, Dynamic Server must abort.
18:51:40 IBM Informix Dynamic Server Started.
18:51:41 Requested shared memory segment size rounded from 65535KB to 65536KB
Sun Apr 01 18:51:41 2007
18:51:41 Booting Language <c> from module <>
18:51:41 Loading Module <CNULL>
18:51:41 Booting Language <builtin> from module <>
18:51:41 Loading Module <BUILTINNULL>
18:51:45 IBM Informix Dynamic Server Version 9.40.TC2 Software Serial Number AAA#B000000
18:51:46 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized.
18:51:46 Physical Recovery Started at Page (5:2564).
18:51:47 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
18:51:47 Logical Recovery Started.
18:51:47 10 recovery worker threads will be started.
18:51:52 Logical Recovery has reached the transaction cleanup phase.
18:51:52 Logical Recovery Complete. 4360 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
18:51:53 Dataskip is now OFF for all dbspaces
18:51:54 Checkpoint Completed: duration was 1 seconds.
18:51:54 Checkpoint loguniq 3957, logpos 0xaf9018, timestamp: 452327243
18:51:54 Maximum server connections 0
18:51:54 Init operation complete - Mode Online
18:51:54 On-Line Mode
18:52:23 Checkpoint Completed: duration was 0 seconds.
18:52:23 Checkpoint loguniq 3957, logpos 0xafa018, timestamp: 452327443
18:52:23 Maximum server connections 5
This is a part of the stack trace:
05:11:00 mt_aio_wait(27764688)
05:11:00 chunkio(7, 0xee2a000, 0x1ab2e, 0, 0x1, 661920408, 34) errno 4
AIOREQ *a
2799b66c: 00000000 00000000 00000000 00000000 ........ ........
2799b67c: 00000000 00000000 a0487627 708e7527 ........ .Hv'p.u'
2799b68c: 00000000 00000000 b40c0000 41494f72 ........ ....AIOr
2799b69c: 65710000 00000000 d1070000 00000000 eq...... ........
2799b6ac: 03000000 01040000 0b000000 02000000 ........ ........
2799b6bc: 01000000 00000000 01000000 08477627 ........ .....Gv'
2799b6cc: 00000000 01000000 02000000 01000000 ........ ........
2799b6dc: 00000000 00000000 00000000 ........ ....
05:11:00 logwrite: bfphysio error
Does any kind of overnight anti-virus scan run that opens the chunk files?
Guy
Bill64bits wrote:
> I had a server panic Saturday night and shut down.
> When IDS was manually restarted Sunday morning, it came up fine and
> commited 4360 rows
> This is IDS 9.4.TC2 on Windows 2000.
> This has never happened in the 3 years the server has been running.
>
> Why would this happen?
> Should I be concerned that a drive is going out?
>
> This is a portion of the log:
>
> 05:01:00 Fuzzy Checkpoint Completed: duration was 0 seconds, 237> buffers not flushed,
> timestamp: 452326139.
> 05:01:00 Checkpoint loguniq 3957, logpos 0xaf8b74, timestamp: 452326154
>
> 05:01:00 Maximum server connections 187
> 05:11:00 KAIO: error in kaio_WRITE, kaiocbp = 0x277647c8, errno = 2
> 05:11:00 fildes = 484 (gfd 7), buf = 0x294EA018, nbytes = 4096, offset> = 447930368
> 05:11:00 I/O write chunk 6, pagenum 109358, pagecnt 1 --> errno = 2
> 05:11:00 Logical Logging error for 'OLDRSAM:CKPOINT' in 'logput'
> 05:11:02 Assert Failed: Dynamic Server must abort
> 05:11:02 IBM Informix Dynamic Server Version 9.40.TC2
> 05:11:02 Who: Session(1, informix@bob.cheerco.net
> <mailto:informix@bob.cheerco.net>, 0, 00000000)
> Thread(6, main_loop(), 0, 1)
> File: rslog.c Line: 3406
> 05:11:03 Results: Dynamic Server must abort
> 05:11:03 Action: Reinitialize shared memory
> 05:11:03 stack trace for pid 704 written to H:\\temp\\af.3ee8534
> 05:11:04 See Also: H:\\temp\\af.3ee8534, shmem.3ee8534.0
> 05:13:00 PANIC: Attempting to bring system down
> 05:13:00 rslog.c, line 3406, thread 6, proc id 704, Dynamic Server must
> abort.
> 18:51:40 IBM Informix Dynamic Server Started.
> 18:51:41 Requested shared memory segment size rounded from 65535KB to> 65536KB
>
> Sun Apr 01 18:51:41 2007
>
> 18:51:41 Booting Language <c> from module <>
> 18:51:41 Loading Module <CNULL>
> 18:51:41 Booting Language <builtin> from module <>
> 18:51:41 Loading Module <BUILTINNULL>
> 18:51:45 IBM Informix Dynamic Server Version 9.40.TC2 Software> Serial Number AAA#B000000
> 18:51:46 IBM Informix Dynamic Server Initialized -- Shared Memory> Initialized.
>
> 18:51:46 Physical Recovery Started at Page (5:2564).
> 18:51:47 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored.
> 18:51:47 Logical Recovery Started.
> 18:51:47 10 recovery worker threads will be started.
> 18:51:52 Logical Recovery has reached the transaction cleanup phase.
> 18:51:52 Logical Recovery Complete.> 4360 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 18:51:53 Dataskip is now OFF for all dbspaces
> 18:51:54 Checkpoint Completed: duration was 1 seconds.
> 18:51:54 Checkpoint loguniq 3957, logpos 0xaf9018, timestamp: 452327243
>
> 18:51:54 Maximum server connections 0
> 18:51:54 Init operation complete - Mode Online
> 18:51:54 On-Line Mode
> 18:52:23 Checkpoint Completed: duration was 0 seconds.
> 18:52:23 Checkpoint loguniq 3957, logpos 0xafa018, timestamp: 452327443
>
> 18:52:23 Maximum server connections 5> This is a part of the stack trace:
> 05:11:00 mt_aio_wait(27764688)
> 05:11:00 chunkio(7, 0xee2a000, 0x1ab2e, 0, 0x1, 661920408, 34) errno 4
> AIOREQ *a
> 2799b66c: 00000000 00000000 00000000 00000000 ........ ........
> 2799b67c: 00000000 00000000 a0487627 708e7527 ........ .Hv'p.u'
> 2799b68c: 00000000 00000000 b40c0000 41494f72 ........ ....AIOr
> 2799b69c: 65710000 00000000 d1070000 00000000 eq...... ........
> 2799b6ac: 03000000 01040000 0b000000 02000000 ........ ........
> 2799b6bc: 01000000 00000000 01000000 08477627 ........ .....Gv'
> 2799b6cc: 00000000 01000000 02000000 01000000 ........ ........
> 2799b6dc: 00000000 00000000 00000000 ........ ....
> 05:11:00 logwrite: bfphysio error>