Setting roles - when using isql menu driven forms
Posted in 2007
Topics: Security, Permissions & Auditing, Platform-Specific Issues
http://by124w.bay124.mail.live.com/mail/EditMessageLight.aspx?n=1539849831 Folks, We have to access a database using isql menus/forms. The database has read and write roles setup. When trying to access the database using isql command line options, isql reports an error : 272: No SELECT permission. The reason for this error is because the read role is not setup when the menus are called from the isql command line(see below). 1. Is there a way to set a role when using isql command line options? or is there an environment variable that can be set to tell INFORMIX isql to use that role? Here are the details: INFORMIX Version : 7.31.ud9 Server : Sun Solaris 10 isql 7.32.UC3 Roles: sc_read (read on select tables, granted to to the user using the grant command (grant sc_read to user1)) isql command line invocation: isql -s <database name> -ur (this will directly run the user menus that have been pre-defined) All help appreciated. -- Rajiv Jhaveri rajiv_jhaveri_06@hotmail.com _________________________________________________________________ Its tax season, make sure to follow these few simple tips http://articles.moneycentral.msn.com/Taxes/PreparationTips/PreparationTips.aspx? icid=WLMartagline
Is the equivalent select query is running successfully through ISQL query-language editor? If yes, this is an issue with ISQL & i believe similar issue with menu role permissions is fixed in 7.32.xC4 release. Let me know the update. - Ravikumar. Rajiv Jhaveri <rajiv_jhaveri_06@hotmail.com> wrote: http://by124w.bay124.mail.live.com/mail/EditMessageLight.aspx?n=1539849831 Folks, We have to access a database using isql menus/forms. The database has read and write roles setup. When trying to access the database using isql command line options, isql reports an error : 272: No SELECT permission. The reason for this error is because the read role is not setup when the menus are called from the isql command line(see below). 1. Is there a way to set a role when using isql command line options? or is there an environment variable that can be set to tell INFORMIX isql to use that role? Here are the details: INFORMIX Version : 7.31.ud9 Server : Sun Solaris 10 isql 7.32.UC3 Roles: sc_read (read on select tables, granted to to the user using the grant command (grant sc_read to user1)) isql command line invocation: isql -s -ur (this will directly run the user menus that have been pre-defined) All help appreciated. -- Rajiv Jhaveri rajiv_jhaveri_06@hotmail.com _________________________________________________________________ Its tax season, make sure to follow these few simple tips http://articles.moneycentral.msn.com/Taxes/PreparationTips/PreparationTips.aspx? icid=WLMartagline ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. --------------------------------- Check out what you're missing if you're not on Yahoo! Messenger
Error 272: No SELECT permission is due to role not being setup. If you can pass the first statement in your menu file, then it should work: set role sc_read; Rajiv Jhaveri <rajiv_jhaveri_06@hotmail.com> wrote: http://by124w.bay124.mail.live.com/mail/EditMessageLight.aspx?n=1539849831 Folks, We have to access a database using isql menus/forms. The database has read and write roles setup. When trying to access the database using isql command line options, isql reports an error : 272: No SELECT permission. The reason for this error is because the read role is not setup when the menus are called from the isql command line(see below). 1. Is there a way to set a role when using isql command line options? or is there an environment variable that can be set to tell INFORMIX isql to use that role? Here are the details: INFORMIX Version : 7.31.ud9 Server : Sun Solaris 10 isql 7.32.UC3 Roles: sc_read (read on select tables, granted to to the user using the grant command (grant sc_read to user1)) isql command line invocation: isql -s -ur (this will directly run the user menus that have been pre-defined) All help appreciated. -- Rajiv Jhaveri rajiv_jhaveri_06@hotmail.com _________________________________________________________________ Its tax season, make sure to follow these few simple tips http://articles.moneycentral.msn.com/Taxes/PreparationTips/PreparationTips.aspx? icid=WLMartagline ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. --------------------------------- Ahhh...imagining that irresistible "new car" smell? Check outnew cars at Yahoo! Autos.
H.G, That is exactly what I am trying to find out. How to pass the sql. stmt (set role sc_read) when calling the menus via the command (isql -s <database name> -ur). PS: The menus were created interactively using isql (User Menu option). Thank you to all those who responded. All help appreciated. --Rajiv Jhaverirajiv_jhaveri_06@hotmail.com> To: ids@iiug.org> From: hariog@yahoo.com> Subject: Re: Setting roles - when using isql menu drive.... [8923]> Date: Mon, 16 Apr 2007 19:37:47 -0400> > Error 272: No SELECT permission is due to role not being setup. If you can > pass the first statement in your menu file, then it should work: > > set role sc_read; > > Rajiv Jhaveri <rajiv_jhaveri_06@hotmail.com> wrote: > http://by124w.bay124.mail.live.com/mail/EditMessageLight.aspx?n=1539849831 > Folks, > > We have to access a database using isql menus/forms. The database has read and > write roles setup. When trying to access the database using isql command line > options, isql reports an error : 272: No SELECT permission. > > The reason for this error is because the read role is not setup when the menus > are called from the isql command line(see below). > > 1. Is there a way to set a role when using isql command line options? or is > there an environment variable that can be set to tell INFORMIX isql to use > that role? > > Here are the details: > INFORMIX Version : 7.31.ud9 > Server : Sun Solaris 10 > isql 7.32.UC3 > > Roles: > > sc_read (read on select tables, granted to to the user using the grant command > (grant sc_read to user1)) > > isql command line invocation: > > isql -s -ur (this will directly run the user menus that have > been pre-defined) > > All help appreciated. > > -- > Rajiv Jhaveri > rajiv_jhaveri_06@hotmail.com > _________________________________________________________________ > Its tax season, make sure to follow these few simple tips > > > http://articles.moneycentral.msn.com/Taxes/PreparationTips/PreparationTips.aspx? icid=WLMartagline > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --------------------------------- > Ahhh...imagining that irresistible "new car" smell? > Check outnew cars at Yahoo! Autos. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > _________________________________________________________________ News, entertainment and everything you care about at Live.com. Get it now! http://www.live.com/getstarted.aspx