Re: table extents
Posted in 2003
"Gorazd Hribar Rajteri'" <gorazd.hribar@telekom.si> wrote in message news:RCy9b.2850$2B6.621071@news.siol.net... > Use: > ALTER TABLE <table name> INIT IN <dbspace name> > you can use the same dbspace, where your table is created originally. The > whole table will be rebuilt and number of extents will be minimized. You can > use: > ALTER TABLE <table name> MODIFY NEXT SIZE <new number> > prior running ALTER FRAGMENT clause to ensure sane values for next extent > sizes. Note that on IDS 7.31 and prior values over 2 GB have no effect (at > least on Sun machines). Well, on any platform. "Fixed" in IDS 9.40. A few other things to bear in mind: if the target dbspace is itself fragmented (ie lots of small blocks of free space) the ALTER FRAGMENT can fail through exceeding the maximum number of extents for a tablespace. Also, on large tables this is best done with database logging off for performance and for avoidance of long transactions.