RE: Linux kernel 2.2.3
Posted in 1999
The following was posted to the Linux Informix mailing list in February.
All Users of Informix on Linux should monitor that list as well as the IDN
list at Informix in addition to CDI.
Art S. Kagel, kagel@bloomberg.net
---- Original Msg from: Rob Zook <linux-informix@iiug.org> At: 2/26 9:15
Orlando Andico wrote:
>
> Hello all,
>
> I tried Marco Greco's $0.02 tips on starting up IDS, and I got a huge pile
> of errors in the server log:
>
> 14:40:18 listener-thread: err = -25573: oserr = 11: errstr = : Network> driver cannot accept a connection on the port.
>
> Is this due to "running out of file descriptors?"
>
> There is no other process running off port 2730. Also, the system is
> looking for a "log_full.sh" in /usr/informix even though INFORMIXDIR is
> set to /opt/informix.
>
> I am running Linux 2.2.2 on Red Hat 5.2 base.
A fellow on the idn forum mentioned the same problem, here's what they
came up with:
Will Slater wrote:
>I believe these are the lines that cause the problem (from sys_select()
>in select.c)
>
>snip
>> + ret = -EINVAL;
>> + if (n < 0 || n > KFDS_NR)
>> + goto out_nofds;
>
>On my system KFDS_NR has a value of 1024, informix appears to pass an n
>of 4096 to select() causing -EINVAL to be returned. It does not appear
>to be a simple matter to increase KFDS_NR.
To which Art Mills replied:
>cool
>I bumped up the limits in /usr/src/linux/include/linux
>fs.h
>posix_types.h
>limits.h
>
>NR_FILE 5120
>NR_OPEN 5120
>__FD_SETSIZE 5120
>
>and the errors went away
>
>I havent got a chance to fully test it yet
HTH,
Rob Z.