Re: silent truncation of varchar data
Posted in 1999
Rudolf Fernandes — — source: Informix-list mailing list archive (1991-1998)
I think (don't have a database handy to test this out) that such a truncation will cause an SQL Warning to be issued by Informix. You could try using the WHENEVER WARNING sql statement to resolve your problem. BTW, the default behaviour under a warning condition is, you guessed it, to do nothing i.e CONTINUE. Rudy > Jay Walters wrote: > > > I am wondering if anybody else has come across this problem, with 7.3X > > on Windows NT where extra characters are silently truncated when writing > > a VARCHAR to the database. For example if I try to store the word > > 'foobar' in a VARCHAR(5) Informix does not return an error, but only > > stores 'fooba' in the database. www.airflash.com