Re: Help needed - Unable to start IDS 9.2
Posted in 2004
On Thu, 9 Dec 2004 12:16:06 +0100, Zoltan Hubai
<hubai@transped-ns.com> wrote:
>Hi!
>
>I have a following problem on a windows xp machine runing IDS 9.2. The
>database wouldn't start anymore after a power failure. I getting the
>following errors in the log:
>
>12:24:04 Informix Dynamic Server 2000 Initialized -- Shared Memory>Initialized.
>12:24:04 Physical Recovery Started.
>12:24:04 Physical Recovery Complete: 75 Pages Restored.
>12:24:20 Logical Recovery Started.
>12:25:07 Assert Failed: Rollback error 126
>12:25:07 Informix Dynamic Server 2000 Version 9.20.TC4
>12:25:07 Who: Session(8, informix@aopvirt, 0, 0)
> Thread(14, fast_recvry, 0, 1)
> File: rstrans.c Line: 2216
>12:25:07 Results: Log record (OLDRSAM:HINSERT) in log 87, offset>0x175428 was not rolled back
>12:25:07 Action: Use 'onlog' to view the transaction and repair
>manually.
>12:25:07 stack trace for pid 396 written to C:\\tmp\\af.3f635e6
>12:25:08 See Also: C:\\tmp\\af.3f635e6, shmem.3f635e6.0
>12:25:13 Releasing server from system block
>12:25:45 Rollback error 126
>12:25:46 Assert Failed: Rollback error 126
>12:25:46 Informix Dynamic Server 2000 Version 9.20.TC4
>12:25:46 Who: Session(8, informix@aopvirt, 0, 0)
> Thread(14, fast_recvry, 0, 1)
> File: rsextlog.c Line: 1580
>12:25:46 Results: Log record (OLDRSAM:HINSERT) in log 87, offset>0x175428 was not rolled back
>12:25:46 Action: Use 'onlog' to view the transaction and repair
>manually.
Looks like there's a problem with log 87 . . . disk errors (or
something more sinister) may have mangled that log, and the engine
can't roll it forward.
>
>Is there any way to correct/override this ? There are no backups so
>restore can't solve the problem, and i'm not used to work with informix
>databases so any help is wellcome.
>Now as the database can't start the data can't be exported and as there
>is no backup they afraid they will loose all data.
First thing would be to do a physical restore, then a logical restore
(stopping before log 87), but that doesn't look likely. I don't know
if Informix can dial in and truncate that log on an engine start.
Looks like a call to IBM . . .
JWC