SOLVED: remote tape with ontape (dd command) fail after openssh install
Posted in 2008
I'm ashamed. No openssh problem.
The tape had the flap slided a bit to the locked position.
The status of the device was "Write protected"
$ mt -f /dev/rmt/2u statusVendor 'CERTANCE' Product 'ULTRIUM 2 ' tape drive:
sense key(0x7)= Write Protected residual= 0 retries= 0
file no= 0 block no= 0
And now:
$ mt -f /dev/rmt/2u statusVendor 'CERTANCE' Product 'ULTRIUM 2 ' tape drive:
sense key(0x0)= No Additional Sense residual= 0 retries= 0
file no= 0 block no= 0
Thanks, Guillermo.
-----Mensaje original-----
De: informix-list-bounces@iiug.org [mailto:informix-list-bounces@iiug.org]
En nombre de Guillermo Gómez Valcárcel
Enviado el: jueves, 13 de marzo de 2008 15:18
Para: informix-list@iiug.org
Asunto: RV: remote tape with ontape (dd command) fail after openssh install
I solved the permission denied of root remote command adding remote host to
the .rhosts file of user root. False trail!
The source of problem has to do with the post installation openssh.
I take 6 years backing up my Informix database this way without problems.
My key of the question is:
After install openssh on the tape host,
Why dd shell commands works and ontape dd commands doesn't?
Thanks for all responses.
Guillermo.
-----Mensaje original-----
De: Guillermo Gómez Valcárcel [mailto:guillermo.gomez@grafia.es]
Enviado el: jueves, 13 de marzo de 2008 14:36
Para: 'Guillermo Gómez Valcárcel'
Asunto: RE: remote tape with ontape (dd command) fail after openssh install
I want to add more information fruits of in-depth investigation.
When execute remote command as Informix:
$ rsh gestion echo testTest
When execute as root
wot02# rsh gestion echo test
permission denied
Are ontape dd commands launched as user root?
I will try to config openssh to get permission to root.
Guillermo.
-----Mensaje original-----
De: informix-list-bounces@iiug.org [mailto:informix-list-bounces@iiug.org]
En nombre de Guillermo Gómez Valcárcel
Enviado el: jueves, 13 de marzo de 2008 13:58
Para: informix-list@iiug.org; ids@iiug.org
Asunto: remote tape with ontape (dd command) fail after openssh install
Hi:
Until now I had been archiving our database with ontape throught remote tape
connecting to another host called gestion.
The onconfig parameter is:
TAPEDEV gestion:/dev/rmt/2
Yesterday I install openssh in gestion (the tape host) and now I get dd:
Permission denied when execute ontape command from another host that not
have openssh installed.
Database host: Informix Dynamic Server 9.21.UC5 Solaris 8 without openssh.
Tape host: Solaris 7 with openssh.
$ ontape -s -L 1Please mount tape 1 on gestion:/dev/rmt/2u and press Return to continue ...
Remote tape report:
dd: /dev/rmt/2u: open: Permission denied
could not write archive tape.
Any remote command with dd works without problems:
$ rsh gestion "dd if=/var/tmp/graficos_1999.txt" >
/var/tmp/graficos_1999.txt89+1 records in
89+1 records out
But ontape doesnt. dd fail with Permission denied.
What can I do?
Uninstall on tape host?
Install openssh on database host sent backup correctly?
Please help,
Thanks in advance.
Guillermo Gómez Valcárcel
Madrid, Spain.
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
__________ Información de NOD32, revisión 2944 (20080313) __________
Este mensaje ha sido analizado con NOD32 antivirus system
http://www.nod32.com
__________ Información de NOD32, revisión 2944 (20080313) __________
Este mensaje ha sido analizado con NOD32 antivirus system
http://www.nod32.com
_______________________________________________
Informix-list mailing list
Informix-list@iiug.org
http://www.iiug.org/mailman/listinfo/informix-list
__________ Información de NOD32, revisión 2944 (20080313) __________
Este mensaje ha sido analizado con NOD32 antivirus system
http://www.nod32.com