Re: database restructuring
Posted in 1994
Sorry for the confusion, but I must correct myself. tbload only locks BLOB pages. On tables with no BLOBS, tbload will work regardless of the number of rows, as proven below. The problem is as follows: 1) tbload causes lock table overflow during loads. Bug # 18412: tbload locks blobspaces pages. If a customer has 256,000 blobs in a blobspace, tbunload will work. However, tbload will fail because each blobspace page is locked until tbload completes. The situation results in a run out of lock error. There is no way to use tbunload/tbload in a situation like this. No workaround. This is a "feature". Has anyone encountered this problem with tables containing BLOBS? What was the work around? ############################################################## David Nguyen Internet: davidn@geis.geis.com GE Information Services UUCP: uunet!ge!davidn 401 North Washington Street Voice: 1-301-340-5461 Rockville, MD 20850 USA ############################################################## salwan@techmpc.csg.mot.com writes: > we use tbload/tbunload to load and unload our databases and it works just fine. > we have a 10 GB db (+10GB of mirrors). two of the tables in this db have 15 > million rows. we can tbunload and tbload them just fine. > we have been able to speed up our tbunloads/tbloads by changing the tape drive > which we tbunlaod/tbload to/from. we use a TTI technology scsi tape drive that > does double density and compression and we have been able to cut our times in > half. a level zero backup alsp takes about half the time. but i digress. > when you do these tbloads do you have the database in non-logging mode? the > only reason i ask this is because we do not have any problems with ... > > 1) tbload does row-level locking when it creates the tables. > > 2) tbload locks each Blob pages when it loads.