open files limit in IDS 10.00.FC9
Posted in 2010
Topics: Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi,
I wanted to know the actual limit of opened file descriptors on IDS 10.00.FC9
on solaris 10.
The reason is that I get error messages 211 and 101 (well the client
application gets them):
-101 ISAM error: file is not open.
I searched around for possible causes and found this link:
http://www-01.ibm.com/support/docview.wss?uid=swg21251537
which states that the limit of opened files is between 32705 and 32767
(depending on whether internal system tables are opened or not) and that the
solution is to monitor the client sessions with onstat -g opn to catch those
exceeding sessions. Well, on the above mentioned IDS I get sessions that held
a lot more opened files: in fact, the highest value I get is 46340 for several
tables.
How can I get the actual real limit? Is this hard coded in informix or comes
does IDS take this limit from the OS?
Thanks a lot.
Greets
Gerardo Padierna
It's an OS Kernel tunable parameter for most Unixes.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Advanced DataTools, the IIUG, nor any other
organization with which I am associated either explicitly, implicitly, or by
inference. Neither do those opinions reflect those of other individuals
affiliated with any entity with which I am affiliated nor those of the
entities themselves.
On Fri, Jul 2, 2010 at 4:06 AM, GERARDO PADIERNA <g.padierna@gmail.com>wrote:
> Hi,
> I wanted to know the actual limit of opened file descriptors on IDS
> 10.00.FC9
> on solaris 10.
> The reason is that I get error messages 211 and 101 (well the client
> application gets them):
> -101 ISAM error: file is not open.
> I searched around for possible causes and found this link:
> http://www-01.ibm.com/support/docview.wss?uid=swg21251537
> which states that the limit of opened files is between 32705 and 32767
> (depending on whether internal system tables are opened or not) and that
> the
> solution is to monitor the client sessions with onstat -g opn to catch
> those
> exceeding sessions. Well, on the above mentioned IDS I get sessions that
> held
> a lot more opened files: in fact, the highest value I get is 46340 for
> several
> tables.
> How can I get the actual real limit? Is this hard coded in informix or
> comes
> does IDS take this limit from the OS?
>
> Thanks a lot.
> Greets
>
> Gerardo Padierna
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--0016e64608baf460a3048a65a5d6
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g