Informix 7.30/ODBC 3.11/ColdFusion Connexion problem
Posted in 1998
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
Hi,
Could somebody help me with following problem :
ENVIRONNMENT
2 NT 4.0 servers with servicepack 3.0
rdc008 is the primary DNS
rdc009 is a free standing database (Informix IDS workgroup 7.30) server
but in a domain.
Netscape Navigator
Netscape enterprise server 3.5.1
Coldfusion 3.1.1.0
We have set following parameters in setnet32:
CLIENT_LOCALE=en_us.8859-1 (because we need the extended character set fotFrench)
DBDATE=dmy4/DBLANG=en_us.cp1252
Ilogin works fine.
MSAccess can access the datasource.
I have also checked the connexion via sqlconnect and it works :
ODBC Version is : 03
SQL Driver Name is : IVINF13
SQL Driver Version is : 03.11.0000
SQL DBMS Name is : Informix
SQL DBMS Version is : 07.30.0000
PROBLEM
When using the 2.80 ODBC Informix driver, the connexion is established
correctly, but
the facilities required for Coldfusion are not available
(ODBC Error Code S1000 General Error ...String to date conversion error).
which is normal, as ColdFusion requires 3.x ODBC drivers.
When using 3.11 Intersolv ODBC we get follwing error Message :
ODBC Error Code = S1C00 (Driver not capable)
[INTERSOLV][ODBC Informix Driver] Optional Feature not implemented
Could you help us, since we have to install a new application and start it
as per 1.1.99 ?
Many thanks in advance.
regards.
Please email any potential hint to
guy de gonzenbach
regiecentre@swissonline.ch
In article <01be333c$a8e53300$b95118c3@default>,
"R'gie du Centre S.A." <regiecentre@swissonline.ch> wrote:
> Hi,
> Could somebody help me with following problem :
>
> ENVIRONNMENT
>
> 2 NT 4.0 servers with servicepack 3.0
> rdc008 is the primary DNS
> rdc009 is a free standing database (Informix IDS workgroup 7.30) server
> but in a domain.
> Netscape Navigator
> Netscape enterprise server 3.5.1
> Coldfusion 3.1.1.0
>
> We have set following parameters in setnet32:
>
> CLIENT_LOCALE=en_us.8859-1 (because we need the extended character set fot> French)
> DBDATE=dmy4/> DBLANG=en_us.cp1252
>
> Ilogin works fine.
> MSAccess can access the datasource.
> I have also checked the connexion via sqlconnect and it works :
>
> ODBC Version is : 03
> SQL Driver Name is : IVINF13
> SQL Driver Version is : 03.11.0000
> SQL DBMS Name is : Informix
> SQL DBMS Version is : 07.30.0000
>
> PROBLEM
>
> When using the 2.80 ODBC Informix driver, the connexion is established
> correctly, but
> the facilities required for Coldfusion are not available
> (ODBC Error Code S1000 General Error ...String to date conversion error).
> which is normal, as ColdFusion requires 3.x ODBC drivers.
>
> When using 3.11 Intersolv ODBC we get follwing error Message :
>
> ODBC Error Code = S1C00 (Driver not capable)
> [INTERSOLV][ODBC Informix Driver] Optional Feature not implemented
>
> Could you help us, since we have to install a new application and start it
> as per 1.1.99 ?
>
> Many thanks in advance.
> regards.
>
> Please email any potential hint to
> guy de gonzenbach
> regiecentre@swissonline.ch
>
This error says it all: each driver has his own abilities and not all support
the same features (asynchronous working, scrollable cursors, timeout
settings,..). At a certain time the coldfusion app will try to use a certain
function of the driver which is not supported. According to the ODBC spec it
is up to the app. to have a fallback option. You can find out what the app.
is trying to use by making an ODBC trace file via the ODBC administrator. In
the created log file you will see the same errormessage. This will be caused
by the function just before the SQLError function. It is this setting that is
not supported by the driver. Several options here: 1) if it is obvious what
the app is doingm, try playing around with the coldfusion and find a setting
that disables the calling of the function. 2) look in the advanced settings
of the datasource setup as there is normally some extra functionality here
you can enable 3) Try contacting the driver supplier (looks like an intersolv
driver) and include de trace file. I think you can also post in the
newsgroups on their website. Answers are provided by tech reps there.
Toffie.
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
Many thanks for your advice. I partly resolved my problem in getting the connection working, but the response times are now 20 times slower : 3-4 secs to get one tuple from one table as compared with the previous 2.80 response times : 150-200 ms for the first access, 0 ms (data in buffer) when reloading the page. Got an idea ?. In the meantime, I will follow your suggestion and post this problem to the odbc newsgroup. Many thanks again and happy new year Guy