Re: Replication!!
Posted in 1999
Topics: High Availability & Replication, Performance & Tuning, Error Codes & Troubleshooting, Server Administration, Logging & Checkpoints, Jobs, Consulting & Announcements
The "could not find" messages are the result of the retransmissions of
transactions after a line recovery, site reconnection, or reconnected
replicate. They can be ignored. The 243 error is actually the result of a
colision during the cleanup of one of the delete tables. The conflict would
have been between the dtcCleaner thread and one of the CDRDxxx threads (Data
Sync threads) of possibably with one of the grouper threads. It also can be
ignored because the delete table cleaner (CDRDTCleaner) will attempt to remove
the row with a later pass of the delete table (shadow table). We will cause the
CDRDTCleaner thread to lose in a lock condition because the thread that it will
be competing with will either be the CDRGeval or CDRD_ (data sync) thread.
Neither of these two types of messages are cause for alarm. It does not
indicate that data is not being applied on the target.
Since you did not include the output of your message log file, or the onconfig,
I can't make any comment on the size of your log files. We do generally
encourage the following recommendations to avoid problems with ER:
1) Avoid switching log files more than once an hour
2) Try to have 24 hours worth of log space
3) Try to make all of the log files about the same size
4) Keep about 30% difference between LTXHWM and LTXEHWM 40/70 is recommended.
5) Disable idle timeout by setting it to zero
6) Do not use timed based replication unless absolutly necessary. Generally it
does not improve performance.
The keys in the TRG queue that you did include indicate that you might be using
timed based replication. Either that or you suspended and then resumed a
replicate.
Paul wrote:
> Dear all.
> We use Informix NT 7.30 TC7 and we want the data can replicate on two
> difference geographic area by internet. We have done the steps from Informix
> reference book before we create the replicates, but when we finished all the
> difinition of replicates and started the replication, we get the error
> messages:
>
> 11:57:15 CDR GC: replicate pending state recovery complete
> 11:57:15 CDR GC: group recovery complete
> 11:57:15 CDR GC: group pending state recovery complete
> 11:57:15 CDR GC: catalog recovery complete
> 11:57:15 CDR queuer initialization complete
> 11:57:15 CDR NIF Initialization complete
> 11:57:15 DDR Log Snooping - Snooping started in log 644
> 12:00:10 CDR Queuer: could not find element (644/864282/0) in TRG queue
> 12:00:10 CDR Queuer: could not find element (644/864282/1048576) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/2097152) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/3145728) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/4194304) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/5242880) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/6291456) in TRG> queue
> .........
> 12:00:43 dynamically allocated new shared memory segment (size 8388608)
> 12:00:43 CDR CDRDTCleaner: Operation (fanout) select on table deltabview
> failed (sql error -243, isam error 0).>
> We tried to call Informix engineers for help, they first told us that we do
> not have enough logical logs, but we just finished the difinition of
> replicates and still have not any data there, so we asked again, this time
> they told us that errors is the bug of Informix 7.3 TC7 and it will be fix
> until the next version. What's a good answer, how can we do?? We need it
> now!
>
> Help us please. Thanks in advance!
Paul wrote:
> Dear all.
> We use Informix NT 7.30 TC7 and we want the data can replicate on two
> difference geographic area by internet. We have done the steps from Informix
> reference book before we create the replicates, but when we finished all the
> difinition of replicates and started the replication, we get the error
> messages:
>
> 11:57:15 CDR GC: replicate pending state recovery complete
> 11:57:15 CDR GC: group recovery complete
> 11:57:15 CDR GC: group pending state recovery complete
> 11:57:15 CDR GC: catalog recovery complete
> 11:57:15 CDR queuer initialization complete
> 11:57:15 CDR NIF Initialization complete
> 11:57:15 DDR Log Snooping - Snooping started in log 644
> 12:00:10 CDR Queuer: could not find element (644/864282/0) in TRG queue
> 12:00:10 CDR Queuer: could not find element (644/864282/1048576) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/2097152) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/3145728) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/4194304) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/5242880) in TRG> queue
> 12:00:10 CDR Queuer: could not find element (644/864282/6291456) in TRG> queue
> .........
> 12:00:43 dynamically allocated new shared memory segment (size 8388608)
> 12:00:43 CDR CDRDTCleaner: Operation (fanout) select on table deltabview
> failed (sql error -243, isam error 0).>
> We tried to call Informix engineers for help, they first told us that we do
> not have enough logical logs, but we just finished the difinition of
> replicates and still have not any data there, so we asked again, this time
> they told us that errors is the bug of Informix 7.3 TC7 and it will be fix
> until the next version. What's a good answer, how can we do?? We need it
> now!
>
> Help us please. Thanks in advance!
Dear sir. Thanks you very much! We will try your recommendations. We have 300 logical logs now for each 2MB size and we use continus logical log backup and the other are all same as your recommendations.
Dear sir. Could you please tell me what the error means, we can't create replicates. GC operation define replicate 'vp_ima' failed: unable to create delete table
I suspect that in the past that you tried to drop syscdr to remove ER from the server. This was probably done by bringing up the engine with CDRBLOCKOUT set and then running "drop database syscdr". That is not a supported technique for many reasons. On of the reasons is that it does not remove the delete tables from a prior session. This causes the inability to recreate replication on a subsequent session because there is a conflict in the name of the delete table. You will need to contact tech support to clean out the delete tables causing the problem. paoching wrote: > Dear sir. > Could you please tell me what the error means, we can't create replicates. > GC operation define replicate 'vp_ima' failed: unable to create delete table