IDS 9.4 Recursive Exception error
Posted in 2010
Topics: Error Codes & Troubleshooting, Server Administration, Transactions, Locking & Isolation, Logging & Checkpoints, Versions, Editions & End-of-Life
Hi, all
informix IDS9.40 FC7XO occur Recursive Exception error ¡Athen system crashed.
there is no AF file.
What is Recursive Exception error ?
Any ideas about the case and solution ?
online.log message :
16:42:52 Recursive Exception - Server exiting
16:42:52 the master daemon Died.
16:42:53 Fatal error in ADM VP at mt.c:12374
16:42:53 Unexpected virtual processor termination, pid = 1779, exit = 0x100
16:42:53 PANIC: Attempting to bring system down
Onconfig :
===============================================================
# System Configuration
NETTYPE ipcshm,3,500,CPU # Configure poll thread(s) for nettype
NETTYPE soctcp,6,600,NET # Configure poll thread(s) for nettype
DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.
RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor
NUMCPUVPS 3 # Number of user (cpu) vps
SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps to one
NOAGE 1 # Process aging
AFF_SPROC 0 # Affinity start processor
AFF_NPROCS 0 # Affinity number of processors
# Shared Memory Parameters
LOCKS 8000000 # Maximum number of locks
BUFFERS 1024000 # Maximum number of shared buffers 981230 wch
NUMAIOVPS 26 # Number of IO vps
PHYSBUFF 128 # Physical log buffer size (Kbytes)
LOGBUFF 256 # Logical log buffer size (Kbytes)
CLEANERS 64 # Number of buffer cleaner processes
SHMBASE 0x0 # Shared memory base address
SHMVIRTSIZE 2048000 # initial virtual shared memory 981216
SHMADD 256000 # Size of new shared memory segments (Kbytes)
SHMTOTAL 0 # Total shared memory (Kbytes). 0=>unlimited
CKPTINTVL 240 # Check point interval (in sec)
LRUS 512 # Number of LRU queues
LRU_MAX_DIRTY 4.000000 # LRU percent dirty begin cleaning limit
LRU_MIN_DIRTY 3.000000 # LRU percent dirty end cleaning limit
TXTIMEOUT 0x12c # Transaction timeout (in sec)
STACKSIZE 256
You are running a very old version that is out of support and this looks
very much like a very old bug that was fixed long ago. The solution is to
upgrade to a supported version that has the fix. The current release is
11.50.xC6
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
IIUG Board of Directors (art@iiug.org)
See you at the 2010 IIUG Informix Conference
April 25-28, 2010
Overland Park (Kansas City), KS
www.iiug.org/conf
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Advanced DataTools, the IIUG, nor any other
organization with which I am associated either explicitly, implicitly, or by
inference. Neither do those opinions reflect those of other individuals
affiliated with any entity with which I am affiliated nor those of the
entities themselves.
On Thu, Mar 4, 2010 at 2:12 AM, FAN YANG <fania.yang@gmail.com> wrote:
> Hi, all
>
> informix IDS9.40 FC7XO occur Recursive Exception error then system
> crashed.
> there is no AF file.
>
> What is Recursive Exception error ?
>
> Any ideas about the case and solution ?
>
> online.log message :
>
> 16:42:52 Recursive Exception - Server exiting
>
> 16:42:52 the master daemon Died.
>
> 16:42:53 Fatal error in ADM VP at mt.c:12374
>
> 16:42:53 Unexpected virtual processor termination, pid = 1779, exit = 0x100
>
> 16:42:53 PANIC: Attempting to bring system down
>
> Onconfig :
>
> ===============================================================
>
> # System Configuration
>
> NETTYPE ipcshm,3,500,CPU # Configure poll thread(s) for nettype
>
> NETTYPE soctcp,6,600,NET # Configure poll thread(s) for nettype
>
> DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.
>
> RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
>
> MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor
>
> NUMCPUVPS 3 # Number of user (cpu) vps
>
> SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps to one
>
> NOAGE 1 # Process aging
>
> AFF_SPROC 0 # Affinity start processor
>
> AFF_NPROCS 0 # Affinity number of processors>
> # Shared Memory Parameters
>
> LOCKS 8000000 # Maximum number of locks
>
> BUFFERS 1024000 # Maximum number of shared buffers 981230 wch
>
> NUMAIOVPS 26 # Number of IO vps
>
> PHYSBUFF 128 # Physical log buffer size (Kbytes)
>
> LOGBUFF 256 # Logical log buffer size (Kbytes)
>
> CLEANERS 64 # Number of buffer cleaner processes
>
> SHMBASE 0x0 # Shared memory base address
>
> SHMVIRTSIZE 2048000 # initial virtual shared memory 981216
>
> SHMADD 256000 # Size of new shared memory segments (Kbytes)
>
> SHMTOTAL 0 # Total shared memory (Kbytes). 0=>unlimited
>
> CKPTINTVL 240 # Check point interval (in sec)
>
> LRUS 512 # Number of LRU queues
>
> LRU_MAX_DIRTY 4.000000 # LRU percent dirty begin cleaning limit
>
> LRU_MIN_DIRTY 3.000000 # LRU percent dirty end cleaning limit
>
> TXTIMEOUT 0x12c # Transaction timeout (in sec)
>
> STACKSIZE 256>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--000e0ce0b10acb012b0480f7e20a
I know we need to upgrade to a supported version. But it need some time to
plan to upgrafe. Before that, we would like to know what the bug is. In case
we still keep using 9.40, we won't hit the bug again.
thanks in advance,
Fan
>You are running a very old version that is out of support and this looks
>very much like a very old bug that was fixed long ago. The solution is to
>upgrade to a supported version that has the fix. The current release is
>11.50.xC6
>Art
>Art S. Kagel
>Advanced DataTools (www.advancedatatools.com)
>IIUG Board of Directors (art@iiug.org)
On Thu, Mar 4, 2010 at 2:12 AM, FAN YANG <fania.yang@gmail.com> wrote:
> Hi, all
>
> informix IDS9.40 FC7XO occur Recursive Exception error then system
> crashed.
> there is no AF file.
>
> What is Recursive Exception error ?
>
> Any ideas about the case and solution ?
>
> online.log message :
>
> 16:42:52 Recursive Exception - Server exiting
>
> 16:42:52 the master daemon Died.
>
> 16:42:53 Fatal error in ADM VP at mt.c:12374
>
> 16:42:53 Unexpected virtual processor termination, pid = 1779, exit = 0x100
>
> 16:42:53 PANIC: Attempting to bring system down
>
> Onconfig :
>
> ===============================================================
>
> # System Configuration
>
> NETTYPE ipcshm,3,500,CPU # Configure poll thread(s) for nettype
>
> NETTYPE soctcp,6,600,NET # Configure poll thread(s) for nettype
>
> DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed env.
>
> RESIDENT 1 # Forced residency flag (Yes = 1, No = 0)
>
> MULTIPROCESSOR 0 # 0 for single-processor, 1 for multi-processor
>
> NUMCPUVPS 3 # Number of user (cpu) vps
>
> SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps to one
>
> NOAGE 1 # Process aging
>
> AFF_SPROC 0 # Affinity start processor
>
> AFF_NPROCS 0 # Affinity number of processors>
> # Shared Memory Parameters
>
> LOCKS 8000000 # Maximum number of locks
>
> BUFFERS 1024000 # Maximum number of shared buffers 981230 wch
>
> NUMAIOVPS 26 # Number of IO vps
>
> PHYSBUFF 128 # Physical log buffer size (Kbytes)
>
> LOGBUFF 256 # Logical log buffer size (Kbytes)
>
> CLEANERS 64 # Number of buffer cleaner processes
>
> SHMBASE 0x0 # Shared memory base address
>
> SHMVIRTSIZE 2048000 # initial virtual shared memory 981216
>
> SHMADD 256000 # Size of new shared memory segments (Kbytes)
>
> SHMTOTAL 0 # Total shared memory (Kbytes). 0=>unlimited
>
> CKPTINTVL 240 # Check point interval (in sec)
>
> LRUS 512 # Number of LRU queues
>
> LRU_MAX_DIRTY 4.000000 # LRU percent dirty begin cleaning limit
>
> LRU_MIN_DIRTY 3.000000 # LRU percent dirty end cleaning limit
>
> TXTIMEOUT 0x12c # Transaction timeout (in sec)
>
> STACKSIZE 256>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--000e0ce0b10acb012b0480f7e20a
You wrote: Hi, all informix IDS9.40 FC7XO occur Recursive Exception error ¡Athen system crashed. there is no AF file. What is Recursive Exception error ? Any ideas about the case and solution ? Response: The recursive exception error means that 1 thread encountered a signal that was going to bring the server offline, and then in the process of trying to report the problem the server received a 2nd signal (the signals I'm referring to would likely be SEGV or BUS). At which point, it just hard aborts the server to get it offline rather then looping in the signal handling code forever. The problem is that because the server received a 2nd signal while trying to process the 1st one, none of the diagnostic information the server normally provides in the AF file exists because the engine wasn't able to get to the point where it reports that info yet. So unfortunately, because the AF file isn't complete there is very little way to tell what cause the 1st signal. So without engaging tech support, there is not going to be much to tell you what caused the problem and what the solution is because in this type of failure, it's very difficult to tell what was happening at the time of the AF. Generally speaking though if you have been running this version of the product for a long time and this is the 1st time you've seen this type of failure, I'd ask you if you recently changed anything at the application level or server, which may be what triggered this. As it's somewhat unusual for this to start happening out of the blue. Jacques Renaut IBM Informix Advanced Support APD Team