Raghava Ponnapalli wrote:
>
> Hi,
>
> we have row level locking for a table. Suddenly, we started noticing error
> 244 with ISAM error 144. Users CLAIM that they are trying to update rows
> with different primary keys. Questions:
>
> 1.Our database is accessed from all over the world. Just out of curiosity,
> can network cause data to get messed up ? I ask this question because a new
> country just went live and that's when we started noticing this problem.
Your data is not messed up.
> 2. With row level locking , why are we getting this error. Our Power
> Builder (5.0) application does not explicitly lock. Users are doing updates
> on different rows (so they claim). We also have lock mode set to not wait.
There's the problem! ISAM error -144 indicate not that the record is
locked but that the index key is locked. This can happen when a key
value is updated both the original key node and the new key node in the
index must be locked, in each affected index, until the transaction is
committed. The engine does this not the application. You must SET
LOCK MODE TO WAIT 5; (or some other brief value reasonable in your
environment). In this way each user's brief lock will not cause
someone else's transaction to fail.
> 3. Is this a documented bug ?
Actually not a bug at all, but definitely documented behavior.
Art S. Kagel