[Q] dbimport locking mode
Posted in 1996
Leonid Belov — — source: Informix-list mailing list archive (1991-1998)
Hello Informixers,
Is there any way to change locking mode used by "dbimport"?
Dbimport locks table rows, and when it tries to alter big table
- for example, to add foreign key constraint - operation fails with message
"No more locks available". So I need "Lock Table ..." before altering table
and "Unlock ..." after
One method to make it - edit file <export_dir>/<database>.exp/<database>.sql
by hands. Another - write advanced awk script to perform such editions.
Can I set dbimport behaviour by command-line options or by some settings
- but _once_ and forewer?
Increasing number of locks in "onconfig" is not a solution because table
always can contain more rows than this number.
Any help would be appreciated
Leonid