Re: Shared Memory Not released
Posted in 1996
Brian,
Several months ago I was getting a few messages involving being out
of virtual shared memory. After some conversation with Informix I
began to use onmode -F, which will free shared memory segments. The
errors I got were not identical to yours but the consumption of virtual
shared memory was involved. I ran onmode -F several times and
evnetually made it a cron job which ones once every early morning.
I have not had such a failure since. I believe I noted someone
else advocating onmode -F for a different memory problem recently.
Check the manual and use at your own risk.
Hope this helps.
--
Con Woodall Colorado St. U.; Veterinary Teach. Hosp.; Ft. Collins CO 80523,
USofA; 970-491-1244 FAX 970-491-4100 cwoodall@vth1.vth.colostate.edu
"Ask me about my vow of silence!"
--
On 9 Sep 1996, Brian Li wrote:
}
} Dear Informix experts,
}
} We are currently have Informix Dynamic Online running on our HP T500 machine
} and recently have shared memory problem which is only known to be solved
} by brining down and up the database instance(DBA's said so).
} It appears that shared memory used by threads cannot be released even after
} application is close.
}
} I would highly appreciate if anyone can provide me some hints or point me
} to the correct direction. Thanks.
}
} Following is a log from onstat -m command:-
}
} Message Log File: /d2/informix/online.log
} 13:20:49 size of resident + virtual segments 162562048 + 362864640 > 512000000
} total allowed by configuration parameter SHMTOTAL
}
} 13:20:49 out of virtual shared memory
}
} 13:20:49 Assert Failed: WARNING! No memory available for page cleaners
} 13:20:49 Who: Thread(43, flush_sub(0), cadf2444, 3)
} 13:20:49 Results: OnLine may be unable to complete a checkpoint
} 13:20:49 Action: Make more virtual memory available to OnLine
} 13:20:49 See Also: /tempfile/af.3e5ec3
}
} 13:20:49 size of resident + virtual segments 162562048 + 362864640 > 512000000
} total allowed by configuration parameter SHMTOTAL
}
} 13:20:49 out of virtual shared memory
}
} 13:20:49 Assert Failed: WARNING! No memory available for page cleaners
} 13:20:49 Who: Thread(43, flush_sub(0), cadf2444, 3)
} 13:20:49 Results: OnLine may be unable to complete a checkpoint
} 13:20:49 Action: Make more virtual memory available to OnLine
}
}
}