Re: Informix must abort -- HELP SQLERROR -457
Posted in 1998
Hartmut Wieczorek wrote:
>
> Hi all,
> My Informix Online 5.08 go into ABORT MODE while creating a new index
> on a table with about 2.900.000 rows.
> 17:17:52 Process Aborted Abnormally: pid=7033 user=104 us=40001ecc
> flags=101
> 17:17:52 Process Aborted Abnormally (critical section): pid=7033 user=104
> flags=101> It's running on OS SINIX 5.42.
> I set the unlimite partameters to unlimeted, and DBTEMP is big enough.
> I have add a new chunk for dbspace, but this error comes again.
This looks like some user CTR-C'd or kill -9'd a process that was in a
critical section. If you do this on a process attached to a 5.xx
server the server does not know how to release the resources the dead
session was holding so it shuts down to preserve server integrity. You
must NEVER kill a process attached to a 5.xx engine.
Art S. Kagel