Re: UPDATE STATISTICS Problem
Posted in 1998
Rajendra Singh wrote: > > We're having many problems with "update statistics" on our Informix SE database > v 7.24. One of the problems we're having is that whenever we do an "update > statistics high for table x", we get error -567 (cannot write sorted rows), with > ISAM code 24 (too many open files). > > I tried increasing the "nfiles" (max number of open files) parameter in the > (HP-UX, v10.20 on a G50) Kernel by 1400, but that didn't help either. There is > alot of free disk space, and usually there is only one or two users on the > machine. We've also tried rebooting. > > Does anyone know of a solution to this? I've checked the FAQ, searched Usenet, > and the web but didn't come up with anything. I believe that the NFILES kernel parameter is the maximum number of open files per system. There is another parameter which controls the maximum number of open files per process. Art S. Kagel