Getting Error 5012
Posted in 2012
Hi, is anyone familiar with error -5012. I'm getting this a lot and I don't understand what it means. I've looked up the error code but I still can't understand it. Hope someone can shed light. -5012 CSM: received message of unexpected type. A CSM (Communications Support Module), in the database server or in the client, received a message with a type that is inconsistent with the protocol formats and/or internal state. This message is more specific than message -5011 because in this case the protocol data unit that is internally consistent might be carrying a message type that the receiver cannot handle. This error can occur only if a CSM is used. It can be caused by a communications error, by the use of incompatible versions of the CSM in the client and the database server, or by inconsistent configurations of the client and database server CSMs. If this error occurs during context setup (that is, at connection time), The connection establishment fails. If this error occurs after Establishment of the connection, the connection is dropped. Make sure that the release versions of the CSMs types match, and the configurations of client and database server CSMs match. If the problem recurs, contact Technical Support at tsmail@us.ibm.com or the CSM vendor and have the follow